summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a00f0f91..6840c791 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,3 +3,9 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
SUBDIRS = src copylib examples
ACLOCAL_AMFLAGS = -I m4
EXTRA_DIST = AUTHORS COPYING.GPL COPING.AGPL COPYING.LGPL
+
+app:
+ mkdir -p $(PACKAGE)-$(VERSION)-app
+ tar cf - configure.ac AUTHORS README copylib/Makefile.am copylib/*.php examples/blog/*.php examples/blog/*.html examples/blog/Makefile.am examples/blog/web-common/taler-presence.* Makefile.am `find src/ -name "*.c" -o -name "*.h" -o -name Makefile.am` | (cd $(PACKAGE)-$(VERSION)-app ; tar xf -)
+ tar cf $(PACKAGE)-$(VERSION)-app.tgz $(PACKAGE)-$(VERSION)-app
+ rm -rf $(PACKAGE)-$(VERSION)-app