summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f796c57..fdab91e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,12 +1,25 @@
# This Makefile is in the public domain
-SUBDIRS = src
+if DOC_ONLY
+ SUBDIRS = . doc
+else
+ SUBDIRS = . src
if WITH_DOC
SUBDIRS += doc
endif
+endif
+
+@DX_RULES@
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = AUTHORS COPYING.GPL COPYING.AGPL COPYING.LGPL
+EXTRA_DIST = \
+ AUTHORS \
+ COPYING.GPL \
+ COPYING.AGPL \
+ COPYING.LGPL \
+ contrib/gnunet.tag \
+ contrib/microhttpd.tag \
+ Doxyfile
app:
mkdir -p $(PACKAGE)-frontend-$(VERSION)-app