summaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-04-22 19:59:34 +0200
committerChristian Grothoff <christian@grothoff.org>2020-04-22 19:59:34 +0200
commite357b735bf09bcdb201841885e79e9f946582912 (patch)
treeba9f47191fd3b07cb226e3412055fc98f483a1e1 /src/testing/Makefile.am
parent7aaeee0914057eeb64bf6af80b54d7d9e58d1b39 (diff)
downloadmerchant-e357b735bf09bcdb201841885e79e9f946582912.tar.gz
merchant-e357b735bf09bcdb201841885e79e9f946582912.tar.bz2
merchant-e357b735bf09bcdb201841885e79e9f946582912.zip
move libtalermerchanttesting and test cases to src/testing/
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am111
1 files changed, 111 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
new file mode 100644
index 00000000..48053c9b
--- /dev/null
+++ b/src/testing/Makefile.am
@@ -0,0 +1,111 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/backend
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+lib_LTLIBRARIES = \
+ libtalermerchanttesting.la
+
+libtalermerchanttesting_la_LDFLAGS = \
+ -version-info 2:0:0 \
+ -no-undefined
+
+libtalermerchanttesting_la_SOURCES = \
+ testing_api_cmd_check_payment.c \
+ testing_api_cmd_config.c \
+ testing_api_cmd_history.c \
+ testing_api_cmd_pay.c \
+ testing_api_cmd_pay_abort.c \
+ testing_api_cmd_pay_abort_refund.c \
+ testing_api_cmd_poll_payment.c \
+ testing_api_cmd_proposal.c \
+ testing_api_cmd_proposal_lookup.c \
+ testing_api_cmd_refund_increase.c \
+ testing_api_cmd_refund_lookup.c \
+ testing_api_cmd_rewind.c \
+ testing_api_cmd_tip_authorize.c \
+ testing_api_cmd_tip_pickup.c \
+ testing_api_cmd_tip_query.c \
+ testing_api_cmd_track_transaction.c \
+ testing_api_cmd_track_transfer.c \
+ testing_api_helpers.c \
+ testing_api_trait_merchant_sig.c \
+ testing_api_trait_string.c \
+ testing_api_trait_hash.c \
+ testing_api_trait_planchet.c \
+ testing_api_trait_refund_entry.c
+
+libtalermerchanttesting_la_LIBADD = \
+ libtalermerchant.la \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetcurl \
+ -lgnunetjson \
+ -lgnunetutil \
+ -ljansson \
+ -ltalertesting \
+ $(XLIB)
+
+
+if HAVE_TALERFAKEBANK
+check_PROGRAMS = \
+ test_merchant_api
+
+if HAVE_TWISTER
+check_PROGRAMS += test_merchant_api_twisted
+endif
+endif
+
+TESTS = \
+ $(check_PROGRAMS)
+
+test_merchant_api_twisted_SOURCES = \
+ test_merchant_api_twisted.c
+test_merchant_api_twisted_LDADD = \
+ $(top_srcdir)/src/backenddb/libtalermerchantdb.la \
+ libtalermerchant.la \
+ $(LIBGCRYPT_LIBS) \
+ -ltalertesting \
+ -ltalermerchanttesting \
+ -ltalertwistertesting \
+ -ltalerfakebank \
+ -ltalerbank \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ -ltalertwister
+
+test_merchant_api_SOURCES = \
+ test_merchant_api.c
+test_merchant_api_LDADD = \
+ $(top_srcdir)/src/backenddb/libtalermerchantdb.la \
+ libtalermerchant.la \
+ $(LIBGCRYPT_LIBS) \
+ -ltalertesting \
+ -ltalermerchanttesting \
+ -ltalerfakebank \
+ -ltalerbank \
+ -ltalerexchange \
+ -ltalerjson \
+ -ltalerutil \
+ -lgnunetjson \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
+EXTRA_DIST = \
+ test_merchant_api.conf \
+ test_merchant_api_twisted.conf \
+ test_merchant_api_proxy_merchant.conf \
+ test_merchant_api_proxy_exchange.conf \
+ test_merchant_api_home/.local/share/taler/exchange/offline-keys/master.priv \
+ test_merchant_api_home/.config/taler/exchange/account-2.json \
+ test_merchant.priv