summaryrefslogtreecommitdiff
path: root/src/mustach/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-07-26 15:03:34 +0200
committerChristian Grothoff <christian@grothoff.org>2020-07-26 15:03:34 +0200
commitcb400751c159fc1fdfa39bc14960da3dd749e637 (patch)
tree11de639a89e36affdcb1087188a86d9f4b2e7089 /src/mustach/Makefile.am
parent7d2465146e6dd1f50d6a8f5121edfa667f1cae84 (diff)
downloadmerchant-cb400751c159fc1fdfa39bc14960da3dd749e637.tar.gz
merchant-cb400751c159fc1fdfa39bc14960da3dd749e637.tar.bz2
merchant-cb400751c159fc1fdfa39bc14960da3dd749e637.zip
vendoring Mustach
Diffstat (limited to 'src/mustach/Makefile.am')
-rw-r--r--src/mustach/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/mustach/Makefile.am b/src/mustach/Makefile.am
new file mode 100644
index 00000000..a39a28d0
--- /dev/null
+++ b/src/mustach/Makefile.am
@@ -0,0 +1,19 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+
+lib_LIBRARIES = \
+ libmustach.a
+
+libmustach_a_SOURCES = \
+ mustach.c mustach.h
+
+check_SCRIPTS = \
+ run-original-tests.sh
+
+TESTS = $(check_SCRIPTS)