summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorMarcello Stanisci <stanisci.m@gmail.com>2018-05-03 15:06:20 +0200
committerMarcello Stanisci <stanisci.m@gmail.com>2018-05-03 15:06:20 +0200
commit96939050ef7d6afe8f0d6ff5b68dbdd940c1c85e (patch)
tree4a16f36acf205818394cda59f1e070990f6ccf24 /src/lib/Makefile.am
parentd89d64100d97b8987521b35fc1d869b9cc65979c (diff)
downloadmerchant-96939050ef7d6afe8f0d6ff5b68dbdd940c1c85e.tar.gz
merchant-96939050ef7d6afe8f0d6ff5b68dbdd940c1c85e.tar.bz2
merchant-96939050ef7d6afe8f0d6ff5b68dbdd940c1c85e.zip
conditions in test code.
It is now possible to use a custom config file and purge the test database only if certains symbols are defined. This is needed for the upcoming payment generator, as it should never purge the database it works on, and supposedly always use the ~/.config/taler.conf default database.
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 39acd3ad..dbc0f074 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -127,6 +127,7 @@ test_merchant_api_new_LDADD = \
-lgnunetcurl \
-lgnunetutil \
-ljansson
+test_merchant_api_new_CFLAGS = -DCUSTOM_CONFIG -DPURGE_DATABASE
test_merchant_api_SOURCES = \
test_merchant_api.c