summaryrefslogtreecommitdiff
path: root/src/backend/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <grothoff@gnunet.org>2023-09-01 14:27:48 +0200
committerChristian Grothoff <grothoff@gnunet.org>2023-09-01 14:27:48 +0200
commit35dcd4514a93ba0f5353ecd1194fc9b515f2aad4 (patch)
tree399d8f8fbebf5e8ac383fc318b7be08901279a31 /src/backend/Makefile.am
parent858e3047b8b595ab693e16ce0bbe0b8983b072ed (diff)
downloadmerchant-35dcd4514a93ba0f5353ecd1194fc9b515f2aad4.tar.gz
merchant-35dcd4514a93ba0f5353ecd1194fc9b515f2aad4.tar.bz2
merchant-35dcd4514a93ba0f5353ecd1194fc9b515f2aad4.zip
new CRUD APIs for OTP devices and merchant accounts (fixes #7929, #7824), one minor test is still failing...
Diffstat (limited to 'src/backend/Makefile.am')
-rw-r--r--src/backend/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/src/backend/Makefile.am b/src/backend/Makefile.am
index fed9c0a2..ef5b67bb 100644
--- a/src/backend/Makefile.am
+++ b/src/backend/Makefile.am
@@ -44,6 +44,8 @@ taler_merchant_httpd_SOURCES = \
taler-merchant-httpd_private-delete-products-ID.h \
taler-merchant-httpd_private-delete-orders-ID.c \
taler-merchant-httpd_private-delete-orders-ID.h \
+ taler-merchant-httpd_private-delete-otp-devices-ID.c \
+ taler-merchant-httpd_private-delete-otp-devices-ID.h \
taler-merchant-httpd_private-delete-reserves-ID.c \
taler-merchant-httpd_private-delete-reserves-ID.h \
taler-merchant-httpd_private-delete-templates-ID.c \
@@ -52,6 +54,10 @@ taler_merchant_httpd_SOURCES = \
taler-merchant-httpd_private-delete-transfers-ID.h \
taler-merchant-httpd_private-delete-webhooks-ID.c \
taler-merchant-httpd_private-delete-webhooks-ID.h \
+ taler-merchant-httpd_private-get-accounts.c \
+ taler-merchant-httpd_private-get-accounts.h \
+ taler-merchant-httpd_private-get-accounts-ID.c \
+ taler-merchant-httpd_private-get-accounts-ID.h \
taler-merchant-httpd_private-get-instances.c \
taler-merchant-httpd_private-get-instances.h \
taler-merchant-httpd_private-get-instances-ID.c \
@@ -66,6 +72,10 @@ taler_merchant_httpd_SOURCES = \
taler-merchant-httpd_private-get-orders.h \
taler-merchant-httpd_private-get-orders-ID.c \
taler-merchant-httpd_private-get-orders-ID.h \
+ taler-merchant-httpd_private-get-otp-devices.c \
+ taler-merchant-httpd_private-get-otp-devices.h \
+ taler-merchant-httpd_private-get-otp-devices-ID.c \
+ taler-merchant-httpd_private-get-otp-devices-ID.h \
taler-merchant-httpd_private-get-reserves.c \
taler-merchant-httpd_private-get-reserves.h \
taler-merchant-httpd_private-get-reserves-ID.c \
@@ -80,16 +90,20 @@ taler_merchant_httpd_SOURCES = \
taler-merchant-httpd_private-get-webhooks.h \
taler-merchant-httpd_private-get-webhooks-ID.c \
taler-merchant-httpd_private-get-webhooks-ID.h \
- taler-merchant-httpd_private-patch-templates-ID.c \
- taler-merchant-httpd_private-patch-templates-ID.h \
- taler-merchant-httpd_private-patch-webhooks-ID.c \
- taler-merchant-httpd_private-patch-webhooks-ID.h \
+ taler-merchant-httpd_private-patch-accounts-ID.c \
+ taler-merchant-httpd_private-patch-accounts-ID.h \
taler-merchant-httpd_private-patch-instances-ID.c \
taler-merchant-httpd_private-patch-instances-ID.h \
taler-merchant-httpd_private-patch-orders-ID-forget.c \
taler-merchant-httpd_private-patch-orders-ID-forget.h \
+ taler-merchant-httpd_private-patch-otp-devices-ID.c \
+ taler-merchant-httpd_private-patch-otp-devices-ID.h \
taler-merchant-httpd_private-patch-products-ID.c \
taler-merchant-httpd_private-patch-products-ID.h \
+ taler-merchant-httpd_private-patch-templates-ID.c \
+ taler-merchant-httpd_private-patch-templates-ID.h \
+ taler-merchant-httpd_private-patch-webhooks-ID.c \
+ taler-merchant-httpd_private-patch-webhooks-ID.h \
taler-merchant-httpd_private-post-account.c \
taler-merchant-httpd_private-post-account.h \
taler-merchant-httpd_private-post-instances.c \
@@ -102,6 +116,8 @@ taler_merchant_httpd_SOURCES = \
taler-merchant-httpd_private-post-orders.h \
taler-merchant-httpd_private-post-products.c \
taler-merchant-httpd_private-post-products.h \
+ taler-merchant-httpd_private-post-otp-devices.c \
+ taler-merchant-httpd_private-post-otp-devices.h \
taler-merchant-httpd_private-post-products-ID-lock.c \
taler-merchant-httpd_private-post-products-ID-lock.h \
taler-merchant-httpd_private-post-reserves.c \