summaryrefslogtreecommitdiff
path: root/doc/doxygen/Makefile.am
diff options
context:
space:
mode:
authorJonathan Buchanan <jonathan.russ.buchanan@gmail.com>2020-06-26 15:36:22 -0400
committerJonathan Buchanan <jonathan.russ.buchanan@gmail.com>2020-06-26 15:36:22 -0400
commit6e47f75016ef5f55f4e81fde77f01647a19d3e25 (patch)
treec0996416419556578fc796125857474e01c423aa /doc/doxygen/Makefile.am
parent2c0797c8f5c236e63b2de86476ac9cdc70c76e22 (diff)
downloadmerchant-6e47f75016ef5f55f4e81fde77f01647a19d3e25.tar.gz
merchant-6e47f75016ef5f55f4e81fde77f01647a19d3e25.tar.bz2
merchant-6e47f75016ef5f55f4e81fde77f01647a19d3e25.zip
updated doxygen generation
Diffstat (limited to 'doc/doxygen/Makefile.am')
-rw-r--r--doc/doxygen/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/Makefile.am b/doc/doxygen/Makefile.am
new file mode 100644
index 00000000..cde28de4
--- /dev/null
+++ b/doc/doxygen/Makefile.am
@@ -0,0 +1,18 @@
+# This Makefile.am is in the public domain
+all:
+ @echo -e \
+"Generate documentation:\n" \
+"\tmake full - full documentation with dependency graphs (slow)\n" \
+"\tmake fast - fast mode without dependency graphs"
+
+full: taler.doxy
+ doxygen $<
+
+fast: taler.doxy
+ sed 's/\(HAVE_DOT.*=\).*/\1 NO/' $< | doxygen -
+
+clean:
+ rm -rf html
+
+EXTRA_DIST = \
+ taler.doxy