summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-10-26 19:53:16 +0200
committerChristian Grothoff <christian@grothoff.org>2016-10-26 19:53:16 +0200
commitdf57ff21ae053f0dc8ab2f198e0c02025872ca09 (patch)
tree144e2b39282c0e586a75f736424878e1b35d9155 /doc/Makefile.am
parentf8b543f2598f7e18a7ac9f3277cf0151331e4bbc (diff)
downloadmerchant-df57ff21ae053f0dc8ab2f198e0c02025872ca09.tar.gz
merchant-df57ff21ae053f0dc8ab2f198e0c02025872ca09.tar.bz2
merchant-df57ff21ae053f0dc8ab2f198e0c02025872ca09.zip
add build rules for arch.pdf
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 6d822548..1f34fda9 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,5 +1,13 @@
+all: manual.pdf
+
+manual.pdf: arch.pdf
+ texi2pdf manual.texi
+arch.pdf: arch.dot
+ dot -Tpdf arch.dot > arch.pdf
+
info_TEXINFOS = manual.texi
manual_TEXINFOS = version.texi
# FIXME. Find a way to compile arch.dot here.
# The command is: dot -Tpng arch.dot > arch.png
+