summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-07-30 11:53:58 +0200
committerFlorian Dold <florian@dold.me>2021-07-30 11:54:13 +0200
commit6495189b10d1333bdb38369371f72d839c97f9f3 (patch)
tree0fd5ad2856b7bf041e21480e7d67c472dccad258 /debian/rules
parent26e6b57afbd1e109ce7cb4364da46838328909d8 (diff)
downloadmerchant-6495189b10d1333bdb38369371f72d839c97f9f3.tar.gz
merchant-6495189b10d1333bdb38369371f72d839c97f9f3.tar.bz2
merchant-6495189b10d1333bdb38369371f72d839c97f9f3.zip
debian: config
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 66d379e4..af1170d0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,6 +31,13 @@ override_dh_auto_install-indep:
override_dh_auto_clean:
dh_auto_clean
+override_dh_installsystemd:
+ # Need to specify units manually, since we have multiple
+ # and dh_installsystemd by default only looks for "<package>.service".
+ dh_installsystemd -ptaler-merchant --name=taler-merchant-httpd --no-start --no-enable
+ # final invocation to generate daemon reload
+ dh_installsystemd
+
# Remove files already present in libtalerexchange from main taler-exchange package
override_dh_install:
dh_install