summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2024-03-03 11:53:52 +0100
committerChristian Grothoff <christian@grothoff.org>2024-03-03 11:53:52 +0100
commit3c9d0e7b78014d448d7be0bbee3c1e83e9baa473 (patch)
treecbbac337ab7ba01858c04c5b9dbb2e62c09f5073 /configure.ac
parented0a15461984c963d25478d820feb2827f7886a1 (diff)
downloadmerchant-3c9d0e7b78014d448d7be0bbee3c1e83e9baa473.tar.gz
merchant-3c9d0e7b78014d448d7be0bbee3c1e83e9baa473.tar.bz2
merchant-3c9d0e7b78014d448d7be0bbee3c1e83e9baa473.zip
implement #8357
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5cc912a..fda84abf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,31 @@ AS_IF([test $libtalerutil != 1],
*** https://taler.net
*** ]])])
+
+libtalermhd=0
+AC_MSG_CHECKING([for libtalermhd])
+AC_ARG_WITH(exchange,
+ [AS_HELP_STRING([--with-exchange=PFX], [base of Taler EXCHANGE installation])],
+ [AC_MSG_RESULT([given as $with_exchange])],
+ [AC_MSG_RESULT(not given)
+ with_exchange=yes])
+AS_CASE([$with_exchange],
+ [yes], [],
+ [no], [AC_MSG_ERROR([--with-exchange is required])],
+ [LDFLAGS="-L$with_exchange/lib $LDFLAGS"
+ CPPFLAGS="-I$with_exchange/include $CPPFLAGS $POSTGRESQL_CPPFLAGS"])
+
+AC_CHECK_HEADERS([taler/taler_mhd_lib.h],
+ [AC_CHECK_LIB([talermhd], [TALER_MHD_parse_request_arg_amount], libtalermhd=1)])
+AM_CONDITIONAL(HAVE_TALERMHD, test x$libtalermhd = x1)
+AS_IF([test $libtalermhd != 1],
+ [AC_MSG_ERROR([[
+***
+*** You need libtalermhd >= 0.9.4a to build this program.
+*** This library is part of the GNU Taler exchange, available at
+*** https://taler.net
+*** ]])])
+
libtalerjson=0
AC_CHECK_HEADERS([taler/taler_json_lib.h],
[AC_CHECK_LIB([talerjson], [TALER_JSON_spec_otp_type], libtalerjson=1)])