aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2023-11-28 00:56:05 +0100
committerFlorian Dold <florian@dold.me>2023-11-28 00:56:05 +0100
commit9ba43cbe9637670ad77023d6d4fdcc9e4687e8fc (patch)
treee2e52e19bb22230c26db55022f7344045e0605f4 /debian
parent171fdd75f8d3e351d244161acb8ee8d635230370 (diff)
downloadlibeufin-9ba43cbe9637670ad77023d6d4fdcc9e4687e8fc.tar.gz
libeufin-9ba43cbe9637670ad77023d6d4fdcc9e4687e8fc.tar.bz2
libeufin-9ba43cbe9637670ad77023d6d4fdcc9e4687e8fc.zip
make sure the compile step is never run under debian fakeroot
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules8
1 files changed, 8 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index f338080b..9d4c909f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,6 +22,14 @@ override_dh_auto_test:
override_dh_auto_configure:
./configure --prefix=/usr
+# Since this step is run under fakeroot and gradle
+# doesn't work under fakeroot, we must make sure
+# that everything is built by gradle before.
+# The install-nobuild target installs under the assumption
+# that everything is already built.
+override_dh_auto_install:
+ make -j1 install-nobuild DESTDIR=$(CURDIR)/debian/tmp
+
# Override this step because it's very slow and likely
# unnecessary for us.
override_dh_strip_nondeterminism: