summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorFlorian Dold <florian@dold.me>2021-07-30 18:48:42 +0200
committerFlorian Dold <florian@dold.me>2021-07-30 18:48:42 +0200
commit3a98855b1cdf0fb81f13124288af57df04952256 (patch)
tree45360f13522cd382dc6dcad7ee9e2ed04acc1166 /debian
parent13083f62ac0dd8275aa4354d81e9328e841efb49 (diff)
downloadlibeufin-3a98855b1cdf0fb81f13124288af57df04952256.tar.gz
libeufin-3a98855b1cdf0fb81f13124288af57df04952256.tar.bz2
libeufin-3a98855b1cdf0fb81f13124288af57df04952256.zip
debian: compat level
Diffstat (limited to 'debian')
-rw-r--r--debian/compat1
-rw-r--r--debian/control10
-rwxr-xr-xdebian/rules23
3 files changed, 23 insertions, 11 deletions
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de3947..00000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index 1858f64a..d86f77e7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,11 @@ Section: net
Priority: optional
Maintainer: Taler Systems SA <deb@taler.net>
Uploaders: Christian Grothoff <grothoff@gnu.org>, Florian Dold <dold@taler.net>
-Build-Depends: debhelper (>= 10),
- unzip,
- openjdk-11-jdk-headless | openjdk-11-jdk,
+Build-Depends:
+ debhelper-compat (= 13),
+ unzip,
+ openjdk-11-jdk-headless | openjdk-11-jdk
+
Standards-Version: 4.1.0
Vcs-Git: https://git.taler.net/libeufin.git
Homepage: https://taler.net/
@@ -15,7 +17,7 @@ Architecture: all
Depends: openjdk-11-jdk-headless | openjdk-11-jdk,
python3 (>= 3.7),
python3-click,
- python3-requests
+ python3-requests,
${misc:Depends}
Recommends:
Description: Software package to access FinTS/EBICS based
diff --git a/debian/rules b/debian/rules
index 2cec8f0b..fb46468a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,18 +1,34 @@
#!/usr/bin/make -f
+
include /usr/share/dpkg/default.mk
+SHELL := sh -e
+
export JAVA_HOME = /usr/lib/jvm/default-java
LIBEUFIN_HOME = /usr/share/libeufin
DEV = -dev.3
FULLVER = $(DEB_VERSION_UPSTREAM)$(DEV)
+
+%:
+ dh ${@}
+
+
clean:
rm -rf libeufin-$(FULLVER)
+
+
build: build-arch build-indep
+
+
build-arch:
true
+
+
build-indep:
true
+
+
override_dh_auto_install:
unzip build/distributions/libeufin-$(FULLVER).zip
dh_install libeufin-$(FULLVER)/lib/nexus-$(FULLVER)-all.jar $(LIBEUFIN_HOME)/lib
@@ -24,12 +40,6 @@ override_dh_auto_install:
dh_link $(LIBEUFIN_HOME)/bin/libeufin-nexus /usr/bin/libeufin-nexus
dh_link $(LIBEUFIN_HOME)/bin/libeufin-sandbox /usr/bin/libeufin-sandbox
-binary:
- dh $@
-binary-arch:
- dh $@
-binary-indep:
- dh $@
# Override this step because it's very slow and likely
# unnecessary for us.
@@ -45,5 +55,6 @@ override_dh_installsystemd:
# final invocation to generate daemon reload
dh_installsystemd
+
get-orig-source:
uscan --force-download --rename