summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-03 11:46:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-03 11:46:45 +0200
commitbac731a21c9aa24b2f5d26bcda68ace9d6148fd3 (patch)
tree9c8698889f05e788be13ee5346af86f6ebe6f98d /configure.ac
parentb9ade5e43f32eb194346fbc55a556670bdf23dd6 (diff)
downloadlanding-bac731a21c9aa24b2f5d26bcda68ace9d6148fd3.tar.gz
landing-bac731a21c9aa24b2f5d26bcda68ace9d6148fd3.tar.bz2
landing-bac731a21c9aa24b2f5d26bcda68ace9d6148fd3.zip
Fix configure.ac: check for typescript compiler missing.
This is required to build web-common.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 37d7dee..10945de 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,7 @@
AC_INIT(taler-demo-landing-page, 0.1, mee@taler.net)
AM_INIT_AUTOMAKE
+# check for typescript compiler
+AC_CHECK_PROG([tsc],[tsc],[yes],[no])
+AM_CONDITIONAL(HAVE_TSC, [ test "$tsc" = "yes"])
AC_CONFIG_FILES(Makefile web-common/Makefile)
AC_OUTPUT