aboutsummaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index a12c00e18..421b4fecb 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -84,7 +84,11 @@ $(srcdir)/getdate.c: getdate.y
$(srcdir)/ca-bundle.h: Makefile.in Makefile
cd $(srcdir) && \
echo "/* The file is generated automaticly */" > $@
+if CABUNDLE
echo '#define CURL_CA_BUNDLE @CURL_CA_BUNDLE@' >> $@
+else
+ echo '#undef CURL_CA_BUNDLE /* unknown */' >> $@
+endif
install-data-hook:
@if test -n "@CURL_CA_BUNDLE@"; then \