summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac66
1 files changed, 33 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 59ffadfa3..3db063459 100755
--- a/configure.ac
+++ b/configure.ac
@@ -3817,39 +3817,39 @@ AM_PATH_PYTHON([2.7],, [:])
AC_SUBST([PYTHON])
AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
-AC_PATH_PROGS( NROFF, gnroff nroff, ,
- $PATH:/usr/bin/:/usr/local/bin )
-AC_SUBST(NROFF)
-
-if test -n "$NROFF"; then
- dnl only check for nroff options if an nroff command was found
-
- AC_MSG_CHECKING([how to use *nroff to get plain text from man pages])
- MANOPT="-man"
- mancheck=`echo foo | $NROFF $MANOPT 2>/dev/null`
- if test -z "$mancheck"; then
- MANOPT="-mandoc"
- mancheck=`echo foo | $NROFF $MANOPT 2>/dev/null`
- if test -z "$mancheck"; then
- MANOPT=""
- AC_MSG_RESULT([failed])
- AC_MSG_WARN([found no *nroff option to get plaintext from man pages])
- else
- AC_MSG_RESULT([$MANOPT])
- fi
- else
- AC_MSG_RESULT([$MANOPT])
- fi
- AC_SUBST(MANOPT)
-fi
-
-if test -z "$MANOPT"
-then
- dnl if no nroff tool was found, or no option that could convert man pages
- dnl was found, then disable the built-in manual stuff
- AC_MSG_WARN([disabling built-in manual])
- USE_MANUAL="yes";
-fi
+dnl AC_PATH_PROGS( NROFF, gnroff nroff, ,
+dnl $PATH:/usr/bin/:/usr/local/bin )
+dnl AC_SUBST(NROFF)
+
+dnl if test -n "$NROFF"; then
+dnl dnl only check for nroff options if an nroff command was found
+
+dnl AC_MSG_CHECKING([how to use *nroff to get plain text from man pages])
+dnl MANOPT="-man"
+dnl mancheck=`echo foo | $NROFF $MANOPT 2>/dev/null`
+dnl if test -z "$mancheck"; then
+dnl MANOPT="-mandoc"
+dnl mancheck=`echo foo | $NROFF $MANOPT 2>/dev/null`
+dnl if test -z "$mancheck"; then
+dnl MANOPT=""
+dnl AC_MSG_RESULT([failed])
+dnl AC_MSG_WARN([found no *nroff option to get plaintext from man pages])
+dnl else
+dnl AC_MSG_RESULT([$MANOPT])
+dnl fi
+dnl else
+dnl AC_MSG_RESULT([$MANOPT])
+dnl fi
+dnl AC_SUBST(MANOPT)
+dnl fi
+
+dnl if test -z "$MANOPT"
+dnl then
+dnl dnl if no nroff tool was found, or no option that could convert man pages
+dnl dnl was found, then disable the built-in manual stuff
+dnl AC_MSG_WARN([disabling built-in manual])
+dnl USE_MANUAL="yes";
+dnl fi
dnl *************************************************************************
dnl If the manual variable still is set, then we go with providing a built-in