summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac167
1 files changed, 140 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index d1faab863..faf2b2129 100755
--- a/configure.ac
+++ b/configure.ac
@@ -155,7 +155,7 @@ AC_SUBST(PKGADD_VENDOR)
dnl
dnl initialize all the info variables
- curl_ssl_msg="no (--with-{ssl,gnutls,nss,polarssl,mbedtls,cyassl,winssl,darwinssl,mesalink} )"
+ curl_ssl_msg="no (--with-{ssl,gnutls,nss,polarssl,mbedtls,cyassl,schannel,secure-transport,mesalink,amissl} )"
curl_ssh_msg="no (--with-libssh2)"
curl_zlib_msg="no (--with-zlib)"
curl_brotli_msg="no (--with-brotli)"
@@ -365,6 +365,7 @@ CURL_CHECK_WIN32_LARGEFILE
CURL_MAC_CFLAGS
CURL_SUPPORTS_BUILTIN_AVAILABLE
+
dnl ************************************************************
dnl switch off particular protocols
dnl
@@ -832,6 +833,28 @@ fi
if test "$HAVE_GETHOSTBYNAME" != "1"
then
+ dnl This is for AmigaOS with bsdsocket.library - needs testing before -lnet
+ AC_MSG_CHECKING([for gethostbyname for AmigaOS bsdsocket.library])
+ AC_LINK_IFELSE([
+ AC_LANG_PROGRAM([[
+#include <proto/bsdsocket.h>
+struct Library *SocketBase = NULL;
+ ]],[[
+ gethostbyname("www.dummysite.com");
+ ]])
+ ],[
+ AC_MSG_RESULT([yes])
+ HAVE_GETHOSTBYNAME="1"
+ HAVE_PROTO_BSDSOCKET_H="1"
+ AC_DEFINE(HAVE_PROTO_BSDSOCKET_H, 1, [if Amiga bsdsocket.library is in use])
+ AC_SUBST(HAVE_PROTO_BSDSOCKET_H, [1])
+ ],[
+ AC_MSG_RESULT([no])
+ ])
+fi
+
+if test "$HAVE_GETHOSTBYNAME" != "1"
+then
dnl gethostbyname in the network lib - for Haiku OS
AC_CHECK_LIB(network, gethostbyname,
[HAVE_GETHOSTBYNAME="1"
@@ -1468,6 +1491,34 @@ dnl check winssl option before other SSL libraries
dnl -------------------------------------------------
OPT_WINSSL=no
+OPT_AMISSL=no
+AC_ARG_WITH(amissl,dnl
+AC_HELP_STRING([--with-amissl],[enable Amiga native SSL/TLS (AmiSSL)])
+AC_HELP_STRING([--without-amissl], [disable Amiga native SSL/TLS (AmiSSL)]),
+ OPT_AMISSL=$withval)
+
+AC_MSG_CHECKING([whether to enable Amiga native SSL/TLS (AmiSSL)])
+if test "$HAVE_PROTO_BSDSOCKET_H" == "1"; then
+ if test -z "$ssl_backends" -o "x$OPT_AMISSL" != xno; then
+ ssl_msg=
+ if test "x$OPT_AMISSL" != "xno"; then
+ AC_MSG_RESULT(yes)
+ ssl_msg="AmiSSL"
+ test amissl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
+ AMISSL_ENABLED=1
+ LIBS="-lamisslauto $LIBS"
+ AC_DEFINE(USE_AMISSL, 1, [if AmiSSL is in use])
+ AC_DEFINE(USE_OPENSSL, 1, [if OpenSSL is in use])
+ else
+ AC_MSG_RESULT(no)
+ fi
+ test -z "$ssl_msg" || ssl_backends="${ssl_backends:+$ssl_backends, }$ssl_msg"
+ else
+ AC_MSG_RESULT(no)
+ fi
+else
+ AC_MSG_RESULT(no)
+fi
dnl **********************************************************************
dnl Check for the presence of SSL libraries and headers
@@ -1765,7 +1816,7 @@ AC_ARG_WITH(libpsl,
with_libpsl=yes)
if test $with_libpsl != "no"; then
AC_SEARCH_LIBS(psl_builtin, psl,
- [curl_psl_msg="yes";
+ [curl_psl_msg="enabled";
AC_DEFINE([USE_LIBPSL], [1], [PSL support enabled])
],
[curl_psl_msg="no (libpsl not found)";
@@ -1773,7 +1824,7 @@ if test $with_libpsl != "no"; then
]
)
fi
-AM_CONDITIONAL([USE_LIBPSL], [test "$curl_psl_msg" = "yes"])
+AM_CONDITIONAL([USE_LIBPSL], [test "$curl_psl_msg" = "enabled"])
dnl **********************************************************************
dnl Check for libmetalink
@@ -1927,9 +1978,9 @@ AC_HELP_STRING([--disable-versioned-symbols], [Disable versioned symbols in shar
elif test "x$CYASSL_ENABLED" = "x1"; then
versioned_symbols_flavour="CYASSL_"
elif test "x$WINSSL_ENABLED" = "x1"; then
- versioned_symbols_flavour="WINSSL_"
- elif test "x$DARWINSSL_ENABLED" = "x1"; then
- versioned_symbols_flavour="DARWINSSL_"
+ versioned_symbols_flavour="SCHANNEL_"
+ elif test "x$SECURETRANSPORT_ENABLED" = "x1"; then
+ versioned_symbols_flavour="SECURE_TRANSPORT_"
else
versioned_symbols_flavour=""
fi
@@ -2215,6 +2266,31 @@ case "$OPT_ZSH_FPATH" in
esac
dnl **********************************************************************
+dnl Check for fish completion path
+dnl **********************************************************************
+
+OPT_FISH_FPATH=default
+AC_ARG_WITH(fish-functions-dir,
+AC_HELP_STRING([--with-fish-functions-dir=PATH],[Install fish completions to PATH])
+AC_HELP_STRING([--without-fish-functions-dir],[Do not install fish completions]),
+ [OPT_FISH_FPATH=$withval])
+case "$OPT_FISH_FPATH" in
+ no)
+ dnl --without-fish-functions-dir option used
+ ;;
+ default|yes)
+ dnl --with-fish-functions-dir option used without path
+ FISH_FUNCTIONS_DIR="$datarootdir/fish/completions"
+ AC_SUBST(FISH_FUNCTIONS_DIR)
+ ;;
+ *)
+ dnl --with-fish-functions-dir option used with path
+ FISH_FUNCTIONS_DIR="$withval"
+ AC_SUBST(FISH_FUNCTIONS_DIR)
+ ;;
+esac
+
+dnl **********************************************************************
dnl Back to "normal" configuring
dnl **********************************************************************
@@ -2299,6 +2375,7 @@ dnl default includes
]
)
+
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
CURL_CHECK_VARIADIC_MACROS
@@ -2419,7 +2496,6 @@ CURL_CHECK_FUNC_CLOSESOCKET
CURL_CHECK_FUNC_CLOSESOCKET_CAMEL
CURL_CHECK_FUNC_CONNECT
CURL_CHECK_FUNC_FCNTL
-CURL_CHECK_FUNC_FDOPEN
CURL_CHECK_FUNC_FREEADDRINFO
CURL_CHECK_FUNC_FREEIFADDRS
CURL_CHECK_FUNC_FSETXATTR
@@ -2841,6 +2917,32 @@ AC_HELP_STRING([--disable-cookies],[Disable cookies support]),
)
dnl ************************************************************
+dnl switch on/off alt-svc
+dnl
+curl_altsvc_msg="no (--enable-alt-svc)";
+AC_MSG_CHECKING([whether to support alt-svc])
+AC_ARG_ENABLE(alt-svc,
+AC_HELP_STRING([--enable-alt-svc],[Enable alt-svc support])
+AC_HELP_STRING([--disable-alt-svc],[Disable alt-svc support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *) AC_MSG_RESULT(yes)
+ curl_altsvc_msg="enabled";
+ enable_altsvc="yes"
+ experimental="alt-svc"
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+if test "$enable_altsvc" = "yes"; then
+ AC_DEFINE(USE_ALTSVC, 1, [to enable alt-svc])
+ experimental="alt-svc"
+fi
+
+dnl ************************************************************
dnl hiding of library internal symbols
dnl
CURL_CONFIGURE_SYMBOL_HIDING
@@ -2908,10 +3010,14 @@ if test "x$HAVE_GSSAPI" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES GSS-API"
fi
-if test "x$curl_psl_msg" = "xyes"; then
+if test "x$curl_psl_msg" = "xenabled"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES PSL"
fi
+if test "x$enable_altsvc" = "xyes"; then
+ SUPPORT_FEATURES="$SUPPORT_FEATURES alt-svc"
+fi
+
if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" -a \
\( "x$HAVE_GSSAPI" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \); then
SUPPORT_FEATURES="$SUPPORT_FEATURES SPNEGO"
@@ -2925,7 +3031,7 @@ fi
if test "x$CURL_DISABLE_CRYPTO_AUTH" != "x1"; then
if test "x$OPENSSL_ENABLED" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$MBEDTLS_ENABLED" = "x1" \
- -o "x$NSS_ENABLED" = "x1" -o "x$DARWINSSL_ENABLED" = "x1"; then
+ -o "x$NSS_ENABLED" = "x1" -o "x$SECURETRANSPORT_ENABLED" = "x1"; then
SUPPORT_FEATURES="$SUPPORT_FEATURES NTLM"
if test "x$CURL_DISABLE_HTTP" != "x1" -a \
@@ -3007,7 +3113,7 @@ if test "x$CURL_DISABLE_SMB" != "x1" \
-a "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" \
-a \( "x$OPENSSL_ENABLED" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$MBEDTLS_ENABLED" = "x1" \
- -o "x$NSS_ENABLED" = "x1" -o "x$DARWINSSL_ENABLED" = "x1" \); then
+ -o "x$NSS_ENABLED" = "x1" -o "x$SECURETRANSPORT_ENABLED" = "x1" \); then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMB"
if test "x$SSL_ENABLED" = "x1"; then
SUPPORT_PROTOCOLS="$SUPPORT_PROTOCOLS SMBS"
@@ -3107,31 +3213,38 @@ AC_MSG_NOTICE([Configured to build gnurl/libgnurl:
LIBS: ${LIBS}
curl version: ${CURLVERSION}
- SSL support: ${curl_ssl_msg}
- SSH support: ${curl_ssh_msg}
- zlib support: ${curl_zlib_msg}
- brotli support: ${curl_brotli_msg}
- GSS-API support: ${curl_gss_msg}
- TLS-SRP support: ${curl_tls_srp_msg}
+ SSL: ${curl_ssl_msg}
+ SSH: ${curl_ssh_msg}
+ zlib: ${curl_zlib_msg}
+ brotli: ${curl_brotli_msg}
+ GSS-API: ${curl_gss_msg}
+ TLS-SRP: ${curl_tls_srp_msg}
resolver: ${curl_res_msg}
- IPv6 support: ${curl_ipv6_msg}
- Unix sockets support: ${curl_unix_sockets_msg}
- IDN support: ${curl_idn_msg}
+ IPv6: ${curl_ipv6_msg}
+ Unix sockets: ${curl_unix_sockets_msg}
+ IDN: ${curl_idn_msg}
Build libcurl: Shared=${enable_shared}, Static=${enable_static}
Built-in manual: ${curl_manual_msg}
--libcurl option: ${curl_libcurl_msg}
Verbose errors: ${curl_verbose_msg}
Code coverage: ${curl_coverage_msg}
- SSPI support: ${curl_sspi_msg}
+ SSPI: ${curl_sspi_msg}
ca cert bundle: ${ca}${ca_warning}
ca cert path: ${capath}${capath_warning}
ca fallback: ${with_ca_fallback}
- LDAP support: ${curl_ldap_msg}
- LDAPS support: ${curl_ldaps_msg}
- RTSP support: ${curl_rtsp_msg}
- RTMP support: ${curl_rtmp_msg}
- metalink support: ${curl_mtlnk_msg}
- PSL support: ${curl_psl_msg}
- HTTP2 support: ${curl_h2_msg}
+ LDAP: ${curl_ldap_msg}
+ LDAPS: ${curl_ldaps_msg}
+ RTSP: ${curl_rtsp_msg}
+ RTMP: ${curl_rtmp_msg}
+ Metalink: ${curl_mtlnk_msg}
+ PSL: ${curl_psl_msg}
+ Alt-svc: ${curl_altsvc_msg}
+ HTTP2: ${curl_h2_msg}
Protocols: ${SUPPORT_PROTOCOLS}
+ Features: ${SUPPORT_FEATURES}
])
+if test -n "$experimental"; then
+ cat >&2 << _EOF
+ WARNING: $experimental is enabled but marked EXPERIMENTAL. Use with caution!
+_EOF
+fi