summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac229
1 files changed, 169 insertions, 60 deletions
diff --git a/configure.ac b/configure.ac
index 6574d1b02..59ffadfa3 100755
--- a/configure.ac
+++ b/configure.ac
@@ -155,7 +155,7 @@ AC_SUBST(PKGADD_VENDOR)
dnl
dnl initialize all the info variables
- curl_ssl_msg="no (--with-{ssl,gnutls,nss,mbedtls,cyassl,schannel,secure-transport,mesalink,amissl} )"
+ curl_ssl_msg="no (--with-{ssl,gnutls,nss,mbedtls,wolfssl,schannel,secure-transport,mesalink,amissl} )"
curl_ssh_msg="no (--with-libssh2)"
curl_zlib_msg="no (--with-zlib)"
curl_brotli_msg="no (--with-brotli)"
@@ -1913,13 +1913,9 @@ if test -z "$ssl_backends" -o "x$OPT_SSL" != xno &&
if test X"$OPENSSL_ENABLED" = X"1"; then
AC_MSG_ERROR([You must not build gnurl with OpenSSL, use --without-ssl!])
dnl These can only exist if OpenSSL exists
- dnl Older versions of Cyassl (some time before 2.9.4) don't have
- dnl SSL_get_shutdown (but this check won't actually detect it there
- dnl as it's a macro that needs the header files be included)
dnl OpenSSL_version is introduced in 3.0.0
AC_CHECK_FUNCS( RAND_egd \
- SSL_get_shutdown \
SSLv2_client_method \
OpenSSL_version )
@@ -2298,48 +2294,48 @@ if test -z "$ssl_backends" -o "x$OPT_MBEDTLS" != xno; then
fi
dnl ----------------------------------------------------
-dnl check for CyaSSL
+dnl check for wolfSSL
dnl ----------------------------------------------------
-dnl Default to compiler & linker defaults for CyaSSL files & libraries.
-OPT_CYASSL=no
+dnl Default to compiler & linker defaults for wolfSSL files & libraries.
+OPT_WOLFSSL=no
_cppflags=$CPPFLAGS
_ldflags=$LDFLAGS
AC_ARG_WITH(cyassl,dnl
AC_HELP_STRING([--with-cyassl=PATH],[where to look for CyaSSL, PATH points to the installation root (default: system lib default)])
AC_HELP_STRING([--without-cyassl], [disable CyaSSL detection]),
- OPT_CYASSL=$withval)
+ OPT_WOLFSSL=$withval)
dnl provide --with-wolfssl as an alias for --with-cyassl
AC_ARG_WITH(wolfssl,dnl
AC_HELP_STRING([--with-wolfssl=PATH],[where to look for WolfSSL, PATH points to the installation root (default: system lib default)])
AC_HELP_STRING([--without-wolfssl], [disable WolfSSL detection]),
- OPT_CYASSL=$withval)
+ OPT_WOLFSSL=$withval)
-if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
+if test -z "$ssl_backends" -o "x$OPT_WOLFSSL" != xno; then
ssl_msg=
- if test X"$OPT_CYASSL" != Xno; then
+ if test X"$OPT_WOLFSSL" != Xno; then
- if test "$OPT_CYASSL" = "yes"; then
- OPT_CYASSL=""
+ if test "$OPT_WOLFSSL" = "yes"; then
+ OPT_WOLFSSL=""
fi
dnl This should be reworked to use pkg-config instead
cyassllibname=cyassl
- if test -z "$OPT_CYASSL" ; then
+ if test -z "$OPT_WOLFSSL" ; then
dnl check for lib in system default first
AC_CHECK_LIB(cyassl, CyaSSL_Init,
dnl libcyassl found, set the variable
[
- AC_DEFINE(USE_CYASSL, 1, [if CyaSSL is enabled])
- AC_SUBST(USE_CYASSL, [1])
- CYASSL_ENABLED=1
- USE_CYASSL="yes"
+ AC_DEFINE(USE_WOLFSSL, 1, [if wolfSSL is enabled])
+ AC_SUBST(USE_WOLFSSL, [1])
+ WOLFSSL_ENABLED=1
+ USE_WOLFSSL="yes"
ssl_msg="CyaSSL"
test cyassl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
])
@@ -2350,11 +2346,11 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
addcflags=""
cyassllib=""
- if test "x$USE_CYASSL" != "xyes"; then
+ if test "x$USE_WOLFSSL" != "xyes"; then
dnl add the path and test again
- addld=-L$OPT_CYASSL/lib$libsuff
- addcflags=-I$OPT_CYASSL/include
- cyassllib=$OPT_CYASSL/lib$libsuff
+ addld=-L$OPT_WOLFSSL/lib$libsuff
+ addcflags=-I$OPT_WOLFSSL/include
+ cyassllib=$OPT_WOLFSSL/lib$libsuff
LDFLAGS="$LDFLAGS $addld"
if test "$addcflags" != "-I/usr/include"; then
@@ -2363,10 +2359,10 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
AC_CHECK_LIB(cyassl, CyaSSL_Init,
[
- AC_DEFINE(USE_CYASSL, 1, [if CyaSSL is enabled])
- AC_SUBST(USE_CYASSL, [1])
- CYASSL_ENABLED=1
- USE_CYASSL="yes"
+ AC_DEFINE(USE_WOLFSSL, 1, [if CyaSSL is enabled])
+ AC_SUBST(USE_WOLFSSL, [1])
+ WOLFSSL_ENABLED=1
+ USE_WOLFSSL="yes"
ssl_msg="CyaSSL"
test cyassl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
],
@@ -2381,11 +2377,11 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
addlib=""
addcflags=""
- if test "x$USE_CYASSL" != "xyes"; then
+ if test "x$USE_WOLFSSL" != "xyes"; then
dnl libcyassl renamed to libwolfssl as of 3.4.0
- addld=-L$OPT_CYASSL/lib$libsuff
- addcflags=-I$OPT_CYASSL/include
- cyassllib=$OPT_CYASSL/lib$libsuff
+ addld=-L$OPT_WOLFSSL/lib$libsuff
+ addcflags=-I$OPT_WOLFSSL/include
+ cyassllib=$OPT_WOLFSSL/lib$libsuff
LDFLAGS="$LDFLAGS $addld"
if test "$addcflags" != "-I/usr/include"; then
@@ -2409,10 +2405,10 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
]])
],[
AC_MSG_RESULT(yes)
- AC_DEFINE(USE_CYASSL, 1, [if CyaSSL/WolfSSL is enabled])
- AC_SUBST(USE_CYASSL, [1])
- CYASSL_ENABLED=1
- USE_CYASSL="yes"
+ AC_DEFINE(USE_WOLFSSL, 1, [if wolfSSL is enabled])
+ AC_SUBST(USE_WOLFSSL, [1])
+ WOLFSSL_ENABLED=1
+ USE_WOLFSSL="yes"
ssl_msg="WolfSSL"
test cyassl != "$DEFAULT_SSL_BACKEND" || VALID_DEFAULT_SSL_BACKEND=yes
],
@@ -2425,32 +2421,20 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
LIBS="$my_ac_save_LIBS"
fi
- if test "x$USE_CYASSL" = "xyes"; then
+ if test "x$USE_WOLFSSL" = "xyes"; then
AC_MSG_NOTICE([detected $cyassllibname])
check_for_ca_bundle=1
dnl cyassl/ctaocrypt/types.h needs SIZEOF_LONG_LONG defined!
AX_COMPILE_CHECK_SIZEOF(long long)
- dnl Versions since at least 2.6.0 may have options.h
- AC_CHECK_HEADERS(cyassl/options.h)
-
- dnl Versions since at least 2.9.4 renamed error.h to error-ssl.h
- AC_CHECK_HEADERS(cyassl/error-ssl.h)
-
LIBS="-l$cyassllibname -lm $LIBS"
- if test "x$cyassllibname" = "xwolfssl"; then
- dnl Recent WolfSSL versions build without SSLv3 by default
- dnl WolfSSL needs configure --enable-opensslextra to have *get_peer*
- AC_CHECK_FUNCS(wolfSSLv3_client_method \
- wolfSSL_get_peer_certificate \
- wolfSSL_UseALPN)
- else
- dnl Cyassl needs configure --enable-opensslextra to have *get_peer*
- AC_CHECK_FUNCS(CyaSSL_CTX_UseSupportedCurve \
- CyaSSL_get_peer_certificate)
- fi
+ dnl Recent WolfSSL versions build without SSLv3 by default
+ dnl WolfSSL needs configure --enable-opensslextra to have *get_peer*
+ AC_CHECK_FUNCS(wolfSSLv3_client_method \
+ wolfSSL_get_peer_certificate \
+ wolfSSL_UseALPN)
if test -n "$cyassllib"; then
dnl when shared libs were found in a path that the run-time
@@ -2466,7 +2450,7 @@ if test -z "$ssl_backends" -o "x$OPT_CYASSL" != xno; then
fi
- fi dnl CyaSSL not disabled
+ fi dnl wolfSSL not disabled
test -z "$ssl_msg" || ssl_backends="${ssl_backends:+$ssl_backends, }$ssl_msg"
fi
@@ -2693,10 +2677,10 @@ if test -z "$ssl_backends" -o "x$OPT_NSS" != xno; then
test -z "$ssl_msg" || ssl_backends="${ssl_backends:+$ssl_backends, }$ssl_msg"
fi
-case "x$OPENSSL_ENABLED$GNUTLS_ENABLED$NSS_ENABLED$MBEDTLS_ENABLED$CYASSL_ENABLED$WINSSL_ENABLED$SECURETRANSPORT_ENABLED$MESALINK_ENABLED$AMISSL_ENABLED" in
+case "x$OPENSSL_ENABLED$GNUTLS_ENABLED$NSS_ENABLED$MBEDTLS_ENABLED$WOLFSSL_ENABLED$WINSSL_ENABLED$SECURETRANSPORT_ENABLED$MESALINK_ENABLED$AMISSL_ENABLED" in
x)
AC_MSG_WARN([SSL disabled, you will not be able to use HTTPS, FTPS, NTLM and more.])
- AC_MSG_WARN([Use --with-ssl, --with-gnutls, --with-cyassl, --with-nss, --with-schannel, --with-secure-transport, --with-mesalink or --with-amissl to address this.])
+ AC_MSG_WARN([Use --with-ssl, --with-gnutls, --with-wolfssl, --with-mbedtls, --with-nss, --with-schannel, --with-secure-transport, --with-mesalink or --with-amissl to address this.])
;;
x1)
# one SSL backend is enabled
@@ -3128,8 +3112,8 @@ AC_HELP_STRING([--disable-versioned-symbols], [Disable versioned symbols in shar
versioned_symbols_flavour="GNUTLS_"
elif test "x$NSS_ENABLED" = "x1"; then
versioned_symbols_flavour="NSS_"
- elif test "x$CYASSL_ENABLED" = "x1"; then
- versioned_symbols_flavour="CYASSL_"
+ elif test "x$WOLFSSL_ENABLED" = "x1"; then
+ versioned_symbols_flavour="WOLFSSL_"
elif test "x$WINSSL_ENABLED" = "x1"; then
versioned_symbols_flavour="SCHANNEL_"
elif test "x$SECURETRANSPORT_ENABLED" = "x1"; then
@@ -4073,7 +4057,6 @@ AC_HELP_STRING([--disable-tls-srp],[Disable TLS-SRP authentication]),
[ case "$enableval" in
no)
AC_MSG_RESULT(no)
- AC_DEFINE(CURL_DISABLE_TLS_SRP, 1, [to disable TLS-SRP authentication])
want_tls_srp=no
;;
*) AC_MSG_RESULT(yes)
@@ -4126,7 +4109,7 @@ fi
dnl ************************************************************
dnl disable cookies support
dnl
-AC_MSG_CHECKING([whether to enable support for cookies])
+AC_MSG_CHECKING([whether to support cookies])
AC_ARG_ENABLE(cookies,
AC_HELP_STRING([--enable-cookies],[Enable cookies support])
AC_HELP_STRING([--disable-cookies],[Disable cookies support]),
@@ -4142,6 +4125,132 @@ AC_HELP_STRING([--disable-cookies],[Disable cookies support]),
)
dnl ************************************************************
+dnl disable HTTP authentication support
+dnl
+AC_MSG_CHECKING([whether to support HTTP authentication])
+AC_ARG_ENABLE(http-auth,
+AC_HELP_STRING([--enable-http-auth],[Enable HTTP authentication support])
+AC_HELP_STRING([--disable-http-auth],[Disable HTTP authentication support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_HTTP_AUTH, 1, [disable HTTP authentication])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable DoH support
+dnl
+AC_MSG_CHECKING([whether to support DoH])
+AC_ARG_ENABLE(doh,
+AC_HELP_STRING([--enable-doh],[Enable DoH support])
+AC_HELP_STRING([--disable-doh],[Disable DoH support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_DOH, 1, [disable DoH])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable mime API support
+dnl
+AC_MSG_CHECKING([whether to support the MIME API])
+AC_ARG_ENABLE(mime,
+AC_HELP_STRING([--enable-mime],[Enable mime API support])
+AC_HELP_STRING([--disable-mime],[Disable mime API support]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_MIME, 1, [disable mime API])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable date parsing
+dnl
+AC_MSG_CHECKING([whether to support date parsing])
+AC_ARG_ENABLE(dateparse,
+AC_HELP_STRING([--enable-dateparse],[Enable date parsing])
+AC_HELP_STRING([--disable-dateparse],[Disable date parsing]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_PARSEDATE, 1, [disable date parsing])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable netrc
+dnl
+AC_MSG_CHECKING([whether to support netrc parsing])
+AC_ARG_ENABLE(netrc,
+AC_HELP_STRING([--enable-netrc],[Enable netrc parsing])
+AC_HELP_STRING([--disable-netrc],[Disable netrc parsing]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_NETRC, 1, [disable netrc parsing])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable progress-meter
+dnl
+AC_MSG_CHECKING([whether to support progress-meter])
+AC_ARG_ENABLE(progress-meter,
+AC_HELP_STRING([--enable-progress-meter],[Enable progress-meter])
+AC_HELP_STRING([--disable-progress-meter],[Disable progress-meter]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_PROGRESS_METER, 1, [disable progress-meter])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
+dnl disable shuffle DNS support
+dnl
+AC_MSG_CHECKING([whether to support DNS shuffling])
+AC_ARG_ENABLE(dnsshuffle,
+AC_HELP_STRING([--enable-dnsshuffle],[Enable DNS shuffling])
+AC_HELP_STRING([--disable-dnsshuffle],[Disable DNS shufflinf]),
+[ case "$enableval" in
+ no)
+ AC_MSG_RESULT(no)
+ AC_DEFINE(CURL_DISABLE_SHUFFLE_DNS, 1, [disable DNS shuffling])
+ ;;
+ *) AC_MSG_RESULT(yes)
+ ;;
+ esac ],
+ AC_MSG_RESULT(yes)
+)
+
+dnl ************************************************************
dnl switch on/off alt-svc
dnl
curl_altsvc_msg="no (--enable-alt-svc)";