summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 7 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index edebfc77b..c27c516e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
dnl We don't know the version number "statically" so we use a dash here
-AC_INIT([curl], [-], [a suitable curl mailing list: https://curl.haxx.se/mail/])
+AC_INIT([gnurl], [-], [a suitable curl mailing list: https://curl.haxx.se/mail/])
XC_OVR_ZZ50
XC_OVR_ZZ60
@@ -122,7 +122,7 @@ AC_SUBST([AR])
AC_SUBST(libext)
dnl figure out the libcurl version
-CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/curl/curlver.h`
+CURLVERSION=`$SED -ne 's/^#define LIBCURL_VERSION "\(.*\)".*/\1/p' ${srcdir}/include/gnurl/curlver.h`
XC_CHECK_PROG_CC
XC_AUTOMAKE
AC_MSG_CHECKING([curl version])
@@ -132,7 +132,7 @@ AC_SUBST(CURLVERSION)
dnl
dnl we extract the numerical version for curl-config only
-VERSIONNUM=`$SED -ne 's/^#define LIBCURL_VERSION_NUM 0x\([0-9A-Fa-f]*\).*/\1/p' ${srcdir}/include/curl/curlver.h`
+VERSIONNUM=`$SED -ne 's/^#define LIBCURL_VERSION_NUM 0x\([0-9A-Fa-f]*\).*/\1/p' ${srcdir}/include/gnurl/curlver.h`
AC_SUBST(VERSIONNUM)
dnl Solaris pkgadd support definitions
@@ -1323,14 +1323,7 @@ if test x"$want_gss" = xyes; then
esac
else
LDFLAGS="$LDFLAGS $GSSAPI_LIB_DIR"
- case $host in
- *-hp-hpux*)
- LIBS="-lgss $LIBS"
- ;;
- *)
- LIBS="-lgssapi $LIBS"
- ;;
- esac
+ LIBS="-lgssapi $LIBS"
fi
else
CPPFLAGS="$save_CPPFLAGS"
@@ -3883,7 +3876,7 @@ AC_CONFIG_FILES([Makefile \
docs/libcurl/opts/Makefile \
docs/cmdline-opts/Makefile \
include/Makefile \
- include/curl/Makefile \
+ include/gnurl/Makefile \
src/Makefile \
lib/Makefile \
scripts/Makefile \
@@ -3910,8 +3903,8 @@ AC_CONFIG_FILES([Makefile \
packages/AIX/Makefile \
packages/AIX/RPM/Makefile \
packages/AIX/RPM/curl.spec \
- curl-config \
- libcurl.pc
+ gnurl-config \
+ libgnurl.pc
])
AC_OUTPUT