summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2020-09-21 13:59:33 +0200
committerDaniel Stenberg <daniel@haxx.se>2020-09-21 23:31:39 +0200
commitf4873ebd0be32cf9ae2c389e0b328f0e03211c84 (patch)
treef06fa7fcbe43f10b8831be1b520ca9d47fdd25d7 /lib/CMakeLists.txt
parent6434a73984b2527194d6409021693c7032d17570 (diff)
downloadgnurl-f4873ebd0be32cf9ae2c389e0b328f0e03211c84.tar.gz
gnurl-f4873ebd0be32cf9ae2c389e0b328f0e03211c84.tar.bz2
gnurl-f4873ebd0be32cf9ae2c389e0b328f0e03211c84.zip
krb5: merged security.c and krb specific FTP functions in here
These two files were always tightly connected and it was hard to understand what went into which. This also allows us to make the ftpsend() function static (moved from ftp.c). Removed security.c Renamed curl_sec.h to krb5.h Closes #5987
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 1d71e1490..911c9096d 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -50,15 +50,6 @@ endif()
# # strtoofft.c - specify later
# )
-# # if we have Kerberos 4, right now this is never on
-# #OPTION(CURL_KRB4 "Use Kerberos 4" OFF)
-# IF(CURL_KRB4)
-# SET(CSOURCES ${CSOURCES}
-# krb4.c
-# security.c
-# )
-# ENDIF(CURL_KRB4)
-
# #OPTION(CURL_MALLOC_DEBUG "Debug mallocs in Curl" OFF)
# MARK_AS_ADVANCED(CURL_MALLOC_DEBUG)
# IF(CURL_MALLOC_DEBUG)