summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Harris <paulharris@computer.org>2017-07-06 23:53:41 +0800
committerDaniel Stenberg <daniel@haxx.se>2017-07-07 14:29:26 +0200
commit45f39945ec929f9ac725c318c8657e4b920c22c5 (patch)
tree49ab56bc30220ef933d2028e9176362b2a45162b /lib/CMakeLists.txt
parentbbc9c6d1445e971706801f9e1077330213993e01 (diff)
downloadgnurl-45f39945ec929f9ac725c318c8657e4b920c22c5.tar.gz
gnurl-45f39945ec929f9ac725c318c8657e4b920c22c5.tar.bz2
gnurl-45f39945ec929f9ac725c318c8657e4b920c22c5.zip
cmake: offer CMAKE_DEBUG_POSTFIX when building with MSVC
Removes BUILD_RELEASE_DEBUG_DIRS since it wasn't used anywhere. Closes #1649
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index f6dcbbc31..667754480 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -97,6 +97,13 @@ if(WIN32)
if(NOT CURL_STATICLIB)
# Add "_imp" as a suffix before the extension to avoid conflicting with the statically linked "libcurl.lib"
set_target_properties(${LIB_NAME} PROPERTIES IMPORT_SUFFIX "_imp.lib")
+
+ set_target_properties (${LIB_NAME} PROPERTIES
+ DEBUG_POSTFIX "-d"
+ # Note: no postfix for release variants, let user choose what style of release he wants
+ # MINSIZEREL_POSTFIX "-z"
+ # RELWITHDEBINFO_POSTFIX "-g"
+ )
endif()
endif()