summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorZmey Petroff <zmeypetroff@newmail.ru>2011-04-28 00:05:07 +0400
committerDaniel Stenberg <daniel@haxx.se>2011-04-28 10:12:33 +0200
commit2cbe885c1a4d4f9b64fa0f41582e9d1b68affa25 (patch)
tree1f6fd2e4bea90d1773dc5a47ea6fe6879a5f344f /lib/CMakeLists.txt
parent4a42e5cdaa344755c6bf5317908849619f61798b (diff)
downloadgnurl-2cbe885c1a4d4f9b64fa0f41582e9d1b68affa25.tar.gz
gnurl-2cbe885c1a4d4f9b64fa0f41582e9d1b68affa25.tar.bz2
gnurl-2cbe885c1a4d4f9b64fa0f41582e9d1b68affa25.zip
CMake: improve library search, implement install.
Improved library search by check_function_exists_concat() macro: it does not revert the list of libraries any more. Improved OpenSSL library search: first find zlib, then search for openssl libraries that may depend on zlib. For Unix: openssl libraries can now be detected in nonstandard locations. Supply CMAKE_LIBRARY_PATH to CMake on command line. Added installation capability (very basic one yet).
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index aec1a3c5b..09b976c4c 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -122,3 +122,5 @@ if(WIN32)
set_target_properties(${LIB_NAME} PROPERTIES IMPORT_SUFFIX "_imp.lib")
endif()
endif()
+
+install(TARGETS ${LIB_NAME} DESTINATION lib)