summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorYang Tse <yangsita@gmail.com>2013-01-03 03:53:06 +0100
committerYang Tse <yangsita@gmail.com>2013-01-03 05:50:26 +0100
commit13606bbfdeaa3bac193e1f39a05a9c9b5f15d1b5 (patch)
tree2213bc5bee29121d23b34de0346ee1324295c379 /lib/CMakeLists.txt
parent8f0171bdd498f5febfb9bc93c234c30287227e74 (diff)
downloadgnurl-13606bbfdeaa3bac193e1f39a05a9c9b5f15d1b5.tar.gz
gnurl-13606bbfdeaa3bac193e1f39a05a9c9b5f15d1b5.tar.bz2
gnurl-13606bbfdeaa3bac193e1f39a05a9c9b5f15d1b5.zip
build: make use of 93 lib/*.c renamed files
93 *.c source files renamed to use our standard naming scheme. This change affects 77 files in libcurl's source tree.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt44
1 files changed, 22 insertions, 22 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 09b976c4c..517ffcfed 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -18,18 +18,18 @@ if(MSVC)
endif()
# SET(CSOURCES
-# # memdebug.c -not used
-# # nwlib.c - Not used
-# # strtok.c - specify later
-# # strtoofft.c - specify later
+# # curl_memdebug.c -not used
+# # curl_nwlib.c - Not used
+# # curl_strtok.c - specify later
+# # curl_strtoofft.c - specify later
# )
# # if we have Kerberos 4, right now this is never on
# #OPTION(CURL_KRB4 "Use Kerberos 4" OFF)
# IF(CURL_KRB4)
# SET(CSOURCES ${CSOURCES}
-# krb4.c
-# security.c
+# curl_krb4.c
+# curl_security.c
# )
# ENDIF(CURL_KRB4)
@@ -37,33 +37,33 @@ endif()
# MARK_AS_ADVANCED(CURL_MALLOC_DEBUG)
# IF(CURL_MALLOC_DEBUG)
# SET(CSOURCES ${CSOURCES}
-# memdebug.c
+# curl_memdebug.c
# )
# ENDIF(CURL_MALLOC_DEBUG)
# # only build compat strtoofft if we need to
# IF(NOT HAVE_STRTOLL AND NOT HAVE__STRTOI64)
# SET(CSOURCES ${CSOURCES}
-# strtoofft.c
+# curl_strtoofft.c
# )
# ENDIF(NOT HAVE_STRTOLL AND NOT HAVE__STRTOI64)
if(HAVE_FEATURES_H)
set_source_files_properties(
- cookie.c
- easy.c
- formdata.c
- getenv.c
- nonblock.c
- hash.c
- http.c
- if2ip.c
- mprintf.c
- multi.c
- sendf.c
- telnet.c
- transfer.c
- url.c
+ curl_cookie.c
+ curl_easy.c
+ curl_formdata.c
+ curl_getenv.c
+ curl_nonblock.c
+ curl_hash.c
+ curl_http.c
+ curl_if2ip.c
+ curl_mprintf.c
+ curl_multi.c
+ curl_sendf.c
+ curl_telnet.c
+ curl_transfer.c
+ curl_url.c
COMPILE_FLAGS -D_BSD_SOURCE)
endif(HAVE_FEATURES_H)