aboutsummaryrefslogtreecommitdiff
path: root/docs/libcurl/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Wu <peter@lekensteyn.nl>2017-03-30 14:27:51 +0200
committerPeter Wu <peter@lekensteyn.nl>2017-03-30 23:43:35 +0200
commitec493dbda2323e055c8861503d533870a697ce73 (patch)
tree54444189a17bb8d07e4ae569140c19c95999b86c /docs/libcurl/CMakeLists.txt
parente358a626f8e8f2f8e35f83d5021bed8fc6567149 (diff)
downloadgnurl-ec493dbda2323e055c8861503d533870a697ce73.tar.gz
gnurl-ec493dbda2323e055c8861503d533870a697ce73.tar.bz2
gnurl-ec493dbda2323e055c8861503d533870a697ce73.zip
cmake: fix build with cmake 2.8.12.2
For some reason, CMake 2.8.12.2 did not expand the list argument in a single DEPENDS argument. Remove the quotes, so it gets expanded into multiple arguments for add_custom_command and add_custom_target. Fixes https://github.com/curl/curl/issues/1370 Closes #1372
Diffstat (limited to 'docs/libcurl/CMakeLists.txt')
-rw-r--r--docs/libcurl/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/docs/libcurl/CMakeLists.txt b/docs/libcurl/CMakeLists.txt
index bdbcad45f..0b32c5054 100644
--- a/docs/libcurl/CMakeLists.txt
+++ b/docs/libcurl/CMakeLists.txt
@@ -49,7 +49,7 @@ add_manual_pages(man_MANS)
string(REPLACE ".3" ".html" HTMLPAGES "${man_MANS}")
string(REPLACE ".3" ".pdf" PDFPAGES "${man_MANS}")
-add_custom_target(html DEPENDS "${HTMLPAGES}")
-add_custom_target(pdf DEPENDS "${PDFPAGES}")
+add_custom_target(html DEPENDS ${HTMLPAGES})
+add_custom_target(pdf DEPENDS ${PDFPAGES})
add_subdirectory(opts)