summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarcel Raad <Marcel.Raad@teamviewer.com>2020-08-03 10:33:17 +0200
committerMarcel Raad <Marcel.Raad@teamviewer.com>2020-08-29 10:08:32 +0200
commitf504f18641ebedde8e8b3805472267efa9a9b528 (patch)
tree71c5071e5f6682b37a30f17fe1e702d7fbe0df36 /configure.ac
parent5cfb807bba0e767faed76681c0d414a346d4c43c (diff)
downloadgnurl-f504f18641ebedde8e8b3805472267efa9a9b528.tar.gz
gnurl-f504f18641ebedde8e8b3805472267efa9a9b528.tar.bz2
gnurl-f504f18641ebedde8e8b3805472267efa9a9b528.zip
ntlm: fix condition for curl_ntlm_core usage
`USE_WINDOWS_SSPI` without `USE_WIN32_CRYPTO` but with any other DES backend is fine, but was excluded before. This also fixes test 1013 as the condition for SMB support in configure.ac didn't match the condition in the source code. Now it does. Fixes https://github.com/curl/curl/issues/1262 Closes https://github.com/curl/curl/pull/5771
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 78e0c4f4f..b063070d5 100755
--- a/configure.ac
+++ b/configure.ac
@@ -5099,7 +5099,7 @@ if test "x$CURL_DISABLE_IMAP" != "x1"; then
fi
if test "x$CURL_DISABLE_SMB" != "x1" \
-a "x$CURL_DISABLE_CRYPTO_AUTH" != "x1" \
- -a \( "x$OPENSSL_ENABLED" = "x1" -o "x$USE_WINDOWS_SSPI" = "x1" \
+ -a \( "x$OPENSSL_ENABLED" = "x1" \
-o "x$GNUTLS_ENABLED" = "x1" -o "x$MBEDTLS_ENABLED" = "x1" \
-o "x$NSS_ENABLED" = "x1" -o "x$SECURETRANSPORT_ENABLED" = "x1" \
-o "x$WOLFSSL_NTLM" = "x1" \); then