summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2018-05-31 15:57:54 +0200
committerDaniel Stenberg <daniel@haxx.se>2018-06-01 12:29:21 +0200
commita115c6bbe73175ad6157fce67338d4a18ed768b2 (patch)
tree96ebcf5ff201b42740454ece0e6049a37f17d403 /configure.ac
parent6d8c6289122dad7f0a05b6363d8e3c2cc73d096a (diff)
downloadgnurl-a115c6bbe73175ad6157fce67338d4a18ed768b2.tar.gz
gnurl-a115c6bbe73175ad6157fce67338d4a18ed768b2.tar.bz2
gnurl-a115c6bbe73175ad6157fce67338d4a18ed768b2.zip
fnmatch: use the system one if available
If configure detects fnmatch to be available, use that instead of our custom one for FTP wildcard pattern matching. For standard compliance, to reduce our footprint and to use already well tested and well exercised code. A POSIX fnmatch behaves slightly different than the internal function for a few test patterns currently and the macOS one yet slightly different. Test case 1307 is adjusted for these differences. Closes #2626
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9c4e697de..fa5dc84f5 100755
--- a/configure.ac
+++ b/configure.ac
@@ -3623,7 +3623,8 @@ AC_CHECK_DECLS([getpwuid_r], [], [AC_DEFINE(HAVE_DECL_GETPWUID_R_MISSING, 1, "Se
#include <sys/types.h>]])
-AC_CHECK_FUNCS([geteuid \
+AC_CHECK_FUNCS([fnmatch \
+ geteuid \
getpass_r \
getppid \
getpwuid \