summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authornikita <nikita@n0.is>2020-04-30 14:57:43 +0200
committernikita <nikita@n0.is>2020-04-30 14:57:43 +0200
commite78a29c1d7e4c0d9d5d2400f8935fe6c6db9852e (patch)
treefcebec99976dae264a75fccabd555af2ac77b4ad /Makefile.am
parent55ddc65827f8424ef1c6fe592da07608237cf2ae (diff)
parent53cdc2c963e33bc0cc1a51ad2df79396202e07f8 (diff)
downloadgnurl-e78a29c1d7e4c0d9d5d2400f8935fe6c6db9852e.tar.gz
gnurl-e78a29c1d7e4c0d9d5d2400f8935fe6c6db9852e.tar.bz2
gnurl-e78a29c1d7e4c0d9d5d2400f8935fe6c6db9852e.zip
Merge tag 'curl-7_70_0'
7.70.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am48
1 files changed, 28 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index 29fbc003f..4979ee61e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,7 @@
# | (__| |_| | _ <| |___
# \___|\___/|_| \_\_____|
#
-# Copyright (C) 1998 - 2018, Daniel Stenberg, <daniel@haxx.se>, et al.
+# Copyright (C) 1998 - 2020, Daniel Stenberg, <daniel@haxx.se>, et al.
#
# This software is licensed as described in the file COPYING, which
# you should have received as part of this distribution. The terms
@@ -27,19 +27,27 @@ AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
-CMAKE_DIST = CMakeLists.txt CMake/CMakeConfigurableFile.in \
- CMake/CurlTests.c CMake/FindGSS.cmake CMake/OtherTests.cmake \
- CMake/Platforms/WindowsCache.cmake CMake/Utilities.cmake \
- CMake/Macros.cmake \
- CMake/CurlSymbolHiding.cmake \
- CMake/FindBearSSL.cmake \
- CMake/cmake_uninstall.cmake.in CMake/gnurl-config.cmake.in
+CMAKE_DIST = \
+ CMake/cmake_uninstall.cmake.in \
+ CMake/CMakeConfigurableFile.in \
+ CMake/gnurl-config.cmake.in \
+ CMake/CurlSymbolHiding.cmake \
+ CMake/CurlTests.c \
+ CMake/FindBearSSL.cmake \
+ CMake/FindGSS.cmake \
+ CMake/FindWolfSSL.cmake \
+ CMake/Macros.cmake \
+ CMake/OtherTests.cmake \
+ CMake/Platforms/WindowsCache.cmake \
+ CMake/Utilities.cmake \
+ CMakeLists.txt
+
PLAN9_DIST = plan9/include/mkfile \
plan9/include/mkfile \
plan9/mkfile.proto \
plan9/mkfile \
- plan9/BUILD.PLAN9.txt \
+ plan9/README \
plan9/lib/mkfile.inc \
plan9/lib/mkfile \
plan9/src/mkfile.inc \
@@ -164,15 +172,15 @@ cygwinbin:
# We extend the standard install with a custom hook:
install-data-hook:
- cd include && $(MAKE) install
- cd docs && $(MAKE) install
- cd docs/libcurl && $(MAKE) install
+ (cd include && $(MAKE) install)
+ (cd docs && $(MAKE) install)
+ (cd docs/libcurl && $(MAKE) install)
# We extend the standard uninstall with a custom hook:
uninstall-hook:
- cd include && $(MAKE) uninstall
- cd docs && $(MAKE) uninstall
- cd docs/libcurl && $(MAKE) uninstall
+ (cd include && $(MAKE) uninstall)
+ (cd docs && $(MAKE) uninstall)
+ (cd docs/libcurl && $(MAKE) uninstall)
ca-bundle: lib/mk-ca-bundle.pl
@echo "generating a fresh ca-bundle.crt"
@@ -183,11 +191,11 @@ ca-firefox: lib/firefox-db2pem.sh
./lib/firefox-db2pem.sh lib/ca-bundle.crt
checksrc:
- cd lib && $(MAKE) checksrc
- cd src && $(MAKE) checksrc
- cd tests && $(MAKE) checksrc
- cd include/gnurl && $(MAKE) checksrc
- cd docs/examples && $(MAKE) checksrc
+ (cd lib && $(MAKE) checksrc)
+ (cd src && $(MAKE) checksrc)
+ (cd tests && $(MAKE) checksrc)
+ (cd include/gnurl && $(MAKE) checksrc)
+ (cd docs/examples && $(MAKE) checksrc)
tidy:
(cd src && $(MAKE) tidy)