summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2017-03-22 10:48:20 +0100
committerng0 <ng0@infotropique.org>2017-08-22 15:24:07 +0000
commit9d4fb1c831bc27ba350ae7434703df275b621a1d (patch)
tree77a1acc470ba860b9a06c3450f0680c7ca4affde /Makefile.am
parent956ae6696bf70f3c6b3e0db4b40b1389cd4b69dc (diff)
downloadgnurl-9d4fb1c831bc27ba350ae7434703df275b621a1d.tar.gz
gnurl-9d4fb1c831bc27ba350ae7434703df275b621a1d.tar.bz2
gnurl-9d4fb1c831bc27ba350ae7434703df275b621a1d.zip
make: introduce 'test-nonflaky' target
Running this in the root build dir will invoke the test suite to only run tests not marked as 'flaky'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index aabdc890c..43c7db050 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,6 +193,9 @@ test:
test-full:
@(cd tests; $(MAKE) all full-test)
+test-nonflaky:
+ @(cd tests; $(MAKE) all nonflaky-test)
+
test-torture:
@(cd tests; $(MAKE) all torture-test)