summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitri Tikhonov <dtikhonov@live.com>2017-10-30 08:12:41 -0400
committerDaniel Stenberg <daniel@haxx.se>2017-10-30 15:27:46 +0100
commitd531f33ba2210ef11d0849bc73654e03affd0cfa (patch)
tree70360646ecedccbf1a5579bbe7711152c746fbc6 /CMakeLists.txt
parente240a546a7ac2fa7956adb664b8c40c4dee4f82b (diff)
downloadgnurl-d531f33ba2210ef11d0849bc73654e03affd0cfa.tar.gz
gnurl-d531f33ba2210ef11d0849bc73654e03affd0cfa.tar.bz2
gnurl-d531f33ba2210ef11d0849bc73654e03affd0cfa.zip
timeval: use mach time on MacOS
If clock_gettime() is not supported, use mach_absolute_time() on MacOS. closes #2033
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c41759aa1..3aaeb346e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -878,6 +878,7 @@ check_symbol_exists(setrlimit "${CURL_INCLUDES}" HAVE_SETRLIMIT)
check_symbol_exists(fcntl "${CURL_INCLUDES}" HAVE_FCNTL)
check_symbol_exists(ioctl "${CURL_INCLUDES}" HAVE_IOCTL)
check_symbol_exists(setsockopt "${CURL_INCLUDES}" HAVE_SETSOCKOPT)
+check_function_exists(mach_absolute_time HAVE_MACH_ABSOLUTE_TIME)
# symbol exists in win32, but function does not.
if(WIN32)