summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index f52bc81c6..22bc788b8 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -15,6 +15,18 @@ pkgcfg_DATA = \
EXTRA_DIST = \
paths.conf
+dist_bin_SCRIPTS = taler-config
+
+# See https://www.gnu.org/software/autoconf/manual/autoconf-2.63/html_node/Installation-Directory-Variables.html
+# for and explanation and why this ugliness is necessary.
+edit = sed -e 's|@libdir[@]|$(libdir)|g'
+taler-config: Makefile $(srcdir)/taler-config.in
+ rm -f $@ $@.tmp
+ $(edit) '$(srcdir)/$@.in' >$@.tmp
+ chmod +x $@.tmp
+ chmod a-w $@.tmp
+ mv $@.tmp $@
+
if WALLET_ONLY
lib_LTLIBRARIES = \
libtalerutil_wallet.la