summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c74fe2101..505634381 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -7,7 +7,7 @@ if USE_COVERAGE
endif
-libexecdir = $(pkglibdir)/libexec/
+libexecdir = $(libdir)/taler/libexec
pkgcfgdir = $(prefix)/share/taler/config.d/
@@ -17,7 +17,8 @@ pkgcfg_DATA = \
EXTRA_DIST = \
paths.conf \
- taler-config.in
+ taler-config.in \
+ test_helper_rsa.conf
libexec_PROGRAMS = \
taler-helper-crypto-rsa
@@ -72,9 +73,12 @@ libtalerutil_la_LDFLAGS = \
-export-dynamic -no-undefined
+AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
+
check_PROGRAMS = \
test_amount \
test_crypto \
+ test_helper_rsa \
test_payto \
test_url
@@ -100,6 +104,12 @@ test_payto_LDADD = \
-lgnunetutil \
libtalerutil.la
+test_helper_rsa_SOURCES = \
+ test_helper_rsa.c
+test_helper_rsa_LDADD = \
+ -lgnunetutil \
+ libtalerutil.la
+
test_url_SOURCES = \
test_url.c
test_url_LDADD = \