summaryrefslogtreecommitdiff
path: root/src/templating/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/templating/Makefile.am')
-rw-r--r--src/templating/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/templating/Makefile.am b/src/templating/Makefile.am
new file mode 100644
index 000000000..e0aef033c
--- /dev/null
+++ b/src/templating/Makefile.am
@@ -0,0 +1,50 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include $(LIBGCRYPT_CFLAGS)
+
+if USE_COVERAGE
+ AM_CFLAGS = --coverage -O0
+ XLIB = -lgcov
+endif
+
+
+lib_LTLIBRARIES = \
+ libtalertemplating.la
+
+noinst_LTLIBRARIES = \
+ libmustach.la
+
+libtalertemplating_la_SOURCES = \
+ mustach.c mustach.h \
+ mustach-jansson.c mustach-jansson.h \
+ templating_api.c
+libtalertemplating_la_LIBADD = \
+ -ltalermhd \
+ -ltalerutil \
+ -lgnunetutil \
+ $(XLIB)
+libtalertemplating_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -no-undefined
+
+
+libmustach_la_SOURCES = \
+ mustach.c mustach.h \
+ mustach-jansson.c mustach-jansson.h
+
+test_mustach_jansson_SOURCES = \
+ test_mustach_jansson.c
+test_mustach_jansson_LDADD = \
+ -lgnunetutil \
+ -lmustach.la \
+ $(XLIB)
+
+check_PROGRAMS = \
+ test_mustach_jansson
+
+check_SCRIPTS = \
+ run-original-tests.sh
+
+TESTS = $(check_SCRIPTS) $(check_PROGRAMS)
+
+EXTRA_DIST = \
+ $(check_SCRIPTS)