summaryrefslogtreecommitdiff
path: root/src/pq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/pq/Makefile.am')
-rw-r--r--src/pq/Makefile.am18
1 files changed, 10 insertions, 8 deletions
diff --git a/src/pq/Makefile.am b/src/pq/Makefile.am
index 2ade01e0e..4b192d762 100644
--- a/src/pq/Makefile.am
+++ b/src/pq/Makefile.am
@@ -10,25 +10,26 @@ lib_LTLIBRARIES = \
libtalerpq.la
libtalerpq_la_SOURCES = \
+ pq_common.h pq_common.c \
pq_query_helper.c \
pq_result_helper.c
-
libtalerpq_la_LIBADD = \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetutil -ljansson \
- -lpq $(XLIB)
-
+ -lgnunetpq \
+ -lpq \
+ $(XLIB)
libtalerpq_la_LDFLAGS = \
$(POSTGRESQL_LDFLAGS) \
-version-info 0:0:0 \
- -export-dynamic -no-undefined
-
-TESTS = \
- test_pq
+ -no-undefined
check_PROGRAMS= \
test_pq
+TESTS = \
+ $(check_PROGRAMS)
+
test_pq_SOURCES = \
test_pq.c
test_pq_LDADD = \
@@ -37,4 +38,5 @@ test_pq_LDADD = \
-lgnunetpq \
-lgnunetutil \
-ljansson \
- -lpq $(XLIB)
+ -lpq \
+ $(XLIB)