summaryrefslogtreecommitdiff
path: root/src/mintdb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mintdb/Makefile.am')
-rw-r--r--src/mintdb/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/mintdb/Makefile.am b/src/mintdb/Makefile.am
index 57aa03b93..73ecd975d 100644
--- a/src/mintdb/Makefile.am
+++ b/src/mintdb/Makefile.am
@@ -46,7 +46,8 @@ libtalermintdb_la_LDFLAGS = \
check_PROGRAMS = \
test-mintdb-deposits \
test-mintdb-keyio \
- test-mintdb-postgres
+ test-mintdb-postgres \
+ perf-mintdb
TESTS = \
test-mintdb-postgres
@@ -76,5 +77,17 @@ test_mintdb_postgres_LDADD = \
$(top_srcdir)/src/util/libtalerutil.la \
$(top_srcdir)/src/pq/libtalerpq.la \
-lgnunetutil -ljansson
+
+perf_mintdb_SOURCES = \
+ perf_taler_mintdb.c \
+ perf_taler_mintdb_init.c \
+ perf_taler_mintdb_interpreter.c
+
+perf_mintdb_LDADD = \
+ libtalermintdb.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ -lgnunetutil
+
+
EXTRA_test_mintdb_postgres_DEPENDENCIES = \
libtaler_plugin_mintdb_postgres.la