summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index 59b1f3165..6f4ffbdf9 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -156,6 +156,7 @@ endif
check_PROGRAMS = \
test_exchange_api_keys_cherry_picking_new \
test_exchange_api_overlapping_keys_bug \
+ test_exchange_api_interpreter_on-off \
test_exchange_api_new \
test_auditor_api
@@ -200,6 +201,19 @@ test_exchange_api_new_LDADD = \
-lgnunetutil \
-ljansson
+test_exchange_api_interpreter_on_off_SOURCES = \
+ test_exchange_api_interpreter_on-off.c
+test_exchange_api_interpreter_on_off_LDADD = \
+ libtalertesting.la \
+ libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson
+
test_exchange_api_overlapping_keys_bug_SOURCES = \
test_exchange_api_overlapping_keys_bug.c
test_exchange_api_overlapping_keys_bug_LDADD = \