summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am21
1 files changed, 19 insertions, 2 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 59aeb3212..043b438c7 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -19,7 +19,12 @@ sqlinputs = \
exchange-0001.sql.in \
exchange-0001-part.sql \
shard-0001-part.sql \
- shard-0001.sql.in
+ shard-0001.sql.in \
+ common-0002.sql \
+ exchange-0002.sql.in \
+ exchange-0002-part.sql \
+ shard-0002-part.sql \
+ shard-0002.sql.in
sql_DATA = \
benchmark-0001.sql \
@@ -37,18 +42,30 @@ BUILT_SOURCES = \
CLEANFILES = \
shard-0001.sql \
- exchange-0001.sql
+ exchange-0001.sql \
+ shard-0002.sql \
+ exchange-0002.sql
exchange-0001.sql: common-0001.sql exchange-0001-part.sql exchange-0001.sql.in
chmod +w $@ || true
gcc -E -P -undef - < exchange-0001.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
chmod ugo-w $@
+exchange-0002.sql: common-0002.sql exchange-0002-part.sql exchange-0002.sql.in
+ chmod +w $@ || true
+ gcc -E -P -undef - < exchange-0002.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
+ chmod ugo-w $@
+
shard-0001.sql: common-0001.sql shard-0001-part.sql exchange-0001.sql.in
chmod +w $@ || true
gcc -E -P -undef - < shard-0001.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
chmod ugo-w $@
+shard-0002.sql: common-0002.sql shard-0002-part.sql exchange-0002.sql.in
+ chmod +w $@ || true
+ gcc -E -P -undef - < shard-0002.sql.in 2>/dev/null | sed -e "s/--.*//" | awk 'NF' - >$@
+ chmod ugo-w $@
+
EXTRA_DIST = \
exchangedb.conf \
exchangedb-postgres.conf \