summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 2eb1eb0ad..3df0653ad 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -19,9 +19,19 @@ sql_DATA = \
benchmark-0001.sql \
exchange-0000.sql \
exchange-0001.sql \
- partition-0001.sql \
+ shard-0001.sql \
drop0001.sql
+BUILT_SOURCES = \
+ shard-0001.sql \
+ exchange-0001.sql
+
+exchange-0001.sql: common-0001.sql exchange-0001-part.sql
+ cat common-0001.sql exchange-0001-part.sql >$@
+
+shard-0001.sql: common-0001.sql
+ cp common-0001.sql $@
+
EXTRA_DIST = \
exchangedb.conf \
exchangedb-postgres.conf \