summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d28aca89a..84f2d6b03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,12 +287,12 @@ AS_CASE([$with_jansson],
[no], [AC_MSG_ERROR([--with-jansson is required])],
[LDFLAGS="-L$with_jansson/lib $LDFLAGS"
CPPFLAGS="-I$with_jansson/include $CPPFLAGS"])
-AC_CHECK_LIB(jansson,json_pack,
+AC_CHECK_LIB(jansson,json_dumpb,
[AC_CHECK_HEADER([jansson.h],[jansson=1])])
AS_IF([test $jansson = 0],
[AC_MSG_ERROR([[
***
-*** You need libjansson to build this program.
+*** You need libjansson >= 2.10 to build this program.
*** ]])])