summaryrefslogtreecommitdiff
path: root/src/wire/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-01-25 14:57:32 +0100
committerChristian Grothoff <christian@grothoff.org>2016-01-25 14:57:32 +0100
commit57c1d2318f14c4b5c21609cb96f32517d02752e7 (patch)
treedccb0cf9d1b5c0dd8a1693d023015dbd6f633b00 /src/wire/Makefile.am
parentfae7db7e930af35e3dac9a6980b69464b4317a85 (diff)
downloadexchange-57c1d2318f14c4b5c21609cb96f32517d02752e7.tar.gz
exchange-57c1d2318f14c4b5c21609cb96f32517d02752e7.tar.bz2
exchange-57c1d2318f14c4b5c21609cb96f32517d02752e7.zip
getting aggregator structure laid out for #4141
Diffstat (limited to 'src/wire/Makefile.am')
-rw-r--r--src/wire/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/wire/Makefile.am b/src/wire/Makefile.am
index 528d91014..fb6f25616 100644
--- a/src/wire/Makefile.am
+++ b/src/wire/Makefile.am
@@ -15,6 +15,9 @@ plugin_LTLIBRARIES = \
noinst_LTLIBRARIES = \
libtaler_plugin_wire_template.la
+lib_LTLIBRARIES = \
+ libtalerwire.la
+
libtaler_plugin_wire_test_la_SOURCES = \
plugin_wire_test.c
@@ -47,6 +50,15 @@ libtaler_plugin_wire_template_la_LDFLAGS = \
-lgnunetutil $(XLIB)
+libtalerwire_la_SOURCES = \
+ wire.c
+libtalerwire_la_LIBADD = \
+ -lgnunetutil
+ $(XLIB)
+libtalerwire_la_LDFLAGS = \
+ -version-info 0:0:0 \
+ -export-dynamic -no-undefined
+
TESTS = \
test_sepa_wireformat
@@ -61,4 +73,5 @@ test_sepa_wireformat_SOURCES = \
test_sepa_wireformat_LDADD = \
-lgnunetutil \
-ljansson \
+ libtalerwire.la \
$(top_builddir)/src/util/libtalerutil.la