summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2015-02-17 17:23:13 +0100
committerSree Harsha Totakura <sreeharsha@totakura.in>2015-02-17 17:29:43 +0100
commitbea425de6cbbfb054a19e0f2312c5ef00c2e1bbe (patch)
treef0c5b1b1d1a1df235555dd5ed3a1a624bd3c8886 /src/util/Makefile.am
parent2f51cd3e3ec8a439e54be154a0c5b639483fb919 (diff)
downloadexchange-bea425de6cbbfb054a19e0f2312c5ef00c2e1bbe.tar.gz
exchange-bea425de6cbbfb054a19e0f2312c5ef00c2e1bbe.tar.bz2
exchange-bea425de6cbbfb054a19e0f2312c5ef00c2e1bbe.zip
Fix #3624: Check JSON format for wire deposits (SEPA specification)
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index a7f9fe3f7..a15d42ad8 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -19,3 +19,15 @@ libtalerutil_la_LIBADD = \
libtalerutil_la_LDFLAGS = \
-version-info 0:0:0 \
-export-dynamic -no-undefined
+
+TESTS=\
+ test-json-validations
+
+check_PROGRAMS=\
+ test-json-validations
+
+test_json_validations_SOURCES=test_json_validations.c
+test_json_validations_LDADD=\
+ -lgnunetutil \
+ -ljansson \
+ libtalerutil.la