summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-11-17 11:31:47 +0100
committerChristian Grothoff <christian@grothoff.org>2016-11-17 11:31:47 +0100
commitbd096d39285ef3225ca348ad5b772133675267bd (patch)
treeff540fcf789584f119fa15f945892ef95c9bdbe5 /src/util/Makefile.am
parent21037d013d915e33c2dd3d1de5a34ed544ca6d48 (diff)
parent2e16fbbae44bb596002417b674fbe8ca9dcffa12 (diff)
downloadexchange-bd096d39285ef3225ca348ad5b772133675267bd.tar.gz
exchange-bd096d39285ef3225ca348ad5b772133675267bd.tar.bz2
exchange-bd096d39285ef3225ca348ad5b772133675267bd.zip
Merge branch 'master' of git+ssh://taler.net/exchange
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index c0713df8e..23f34f4ce 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -15,21 +15,7 @@ pkgcfg_DATA = \
EXTRA_DIST = \
paths.conf \
- taler-config.in \
- taler-arm.in
-
-templated_scripts = taler-config taler-arm
-dist_bin_SCRIPTS = $(templated_scripts)
-
-# See https://www.gnu.org/software/autoconf/manual/autoconf-2.63/html_node/Installation-Directory-Variables.html
-# for an explanation and why this ugliness is necessary.
-edit = sed -e 's|@libdir[@]|$(libdir)|g'
-$(templated_scripts): %: Makefile $(srcdir)/%.in
- rm -f $@ $@.tmp
- $(edit) '$(srcdir)/$@.in' >$@.tmp
- chmod +x $@.tmp
- chmod a-w $@.tmp
- mv $@.tmp $@
+ taler-config.in
if WALLET_ONLY
lib_LTLIBRARIES = \