summaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-04-13 17:20:46 +0200
committerChristian Grothoff <christian@grothoff.org>2015-04-13 17:20:46 +0200
commit5827630699a725e24a59d94861b01bad310f6a02 (patch)
treebc5c97ae6966c088d7bd7a9e9d8705816c8eea37 /src/util/Makefile.am
parent93bc450db36ebb41bfcc1c0d7edf5cfedbcf0741 (diff)
downloadexchange-5827630699a725e24a59d94861b01bad310f6a02.tar.gz
exchange-5827630699a725e24a59d94861b01bad310f6a02.tar.bz2
exchange-5827630699a725e24a59d94861b01bad310f6a02.zip
starting with tests for libtalerutil
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am38
1 files changed, 32 insertions, 6 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 2a5cdefef..804ff85a2 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -28,14 +28,40 @@ libtalerutil_la_LDFLAGS = \
-export-dynamic -no-undefined
TESTS = \
- test-json-validations
+ test_amount \
+ test_crypto \
+ test_json \
+ test_wireformats
-check_PROGRAMS=\
- test-json-validations
+check_PROGRAMS= \
+ test_amount \
+ test_crypto \
+ test_json \
+ test_wireformats
-test_json_validations_SOURCES = \
- test_json_validations.c
-test_json_validations_LDADD = \
+
+test_amount_SOURCES = \
+ test_amount.c
+test_amount_LDADD = \
+ -lgnunetutil \
+ libtalerutil.la
+
+test_crypto_SOURCES = \
+ test_crypto.c
+test_crypto_LDADD = \
+ -lgnunetutil \
+ libtalerutil.la
+
+test_json_SOURCES = \
+ test_json.c
+test_json_LDADD = \
+ -lgnunetutil \
+ -ljansson \
+ libtalerutil.la
+
+test_wireformats_SOURCES = \
+ test_wireformats.c
+test_wireformats_LDADD = \
-lgnunetutil \
-ljansson \
libtalerutil.la