summaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorÖzgür Kesim <oec-taler@kesim.org>2023-07-21 12:04:34 +0200
committerÖzgür Kesim <oec-taler@kesim.org>2023-07-21 12:04:34 +0200
commitbe9d23761dfb074766ca78cb2d8a0a0a35ee4dc8 (patch)
treed5b816b9a586f8968a3195bf0f3f897c32ffce52 /src/testing/Makefile.am
parent3162ee861b2f56ab51c62e38814e0c9bf99e0abc (diff)
downloadexchange-be9d23761dfb074766ca78cb2d8a0a0a35ee4dc8.tar.gz
exchange-be9d23761dfb074766ca78cb2d8a0a0a35ee4dc8.tar.bz2
exchange-be9d23761dfb074766ca78cb2d8a0a0a35ee4dc8.zip
[age-withdraw] started to work on tests in testing
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 068d94590..42408ad58 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -156,6 +156,8 @@ check_PROGRAMS = \
test_bank_api_with_fakebank \
test_exchange_api_cs \
test_exchange_api_rsa \
+ test_exchange_api_age_restriction_cs \
+ test_exchange_api_age_restriction_rsa \
test_exchange_api_keys_cherry_picking_cs \
test_exchange_api_keys_cherry_picking_rsa \
test_exchange_api_revocation_cs \
@@ -281,6 +283,40 @@ test_exchange_api_rsa_LDADD = \
-ljansson \
$(XLIB)
+test_exchange_api_age_restriction_cs_SOURCES = \
+ test_exchange_api_age_restriction.c
+test_exchange_api_age_restriction_cs_LDADD = \
+ libtalertesting.la \
+ $(top_builddir)/src/lib/libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/extensions/libtalerextensions.la \
+ -lgnunettesting \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
+test_exchange_api_age_restriction_rsa_SOURCES = \
+ test_exchange_api_age_restriction.c
+test_exchange_api_age_restriction_rsa_LDADD = \
+ libtalertesting.la \
+ $(top_builddir)/src/lib/libtalerexchange.la \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/bank-lib/libtalerbank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ $(top_builddir)/src/extensions/libtalerextensions.la \
+ -lgnunettesting \
+ -lgnunetcurl \
+ -lgnunetutil \
+ -ljansson \
+ $(XLIB)
+
test_exchange_p2p_cs_SOURCES = \
test_exchange_p2p.c
test_exchange_p2p_cs_LDADD = \
@@ -554,6 +590,9 @@ EXTRA_DIST = \
test_exchange_api.conf \
test_exchange_api-cs.conf \
test_exchange_api-rsa.conf \
+ test_exchange_api_age_restiction.conf \
+ test_exchange_api_age_restiction-cs.conf \
+ test_exchange_api_age_restiction-rsa.conf \
test_exchange_api_twisted.conf \
test_exchange_api_twisted-cs.conf \
test_exchange_api_twisted-rsa.conf \