summaryrefslogtreecommitdiff
path: root/src/testing/Makefile.am
diff options
context:
space:
mode:
authorÖzgür Kesim <oec-taler@kesim.org>2023-12-23 14:56:12 +0100
committerÖzgür Kesim <oec-taler@kesim.org>2023-12-23 14:56:12 +0100
commit13bb37b6a811451accc14b3501173637f2c28d10 (patch)
treed87d5e24f9b3fb82bee5e7ef5bd0de673e2aefe0 /src/testing/Makefile.am
parent8fd6a4e148a93aab45082cbe159a56be05acd1c4 (diff)
downloadexchange-13bb37b6a811451accc14b3501173637f2c28d10.tar.gz
exchange-13bb37b6a811451accc14b3501173637f2c28d10.tar.bz2
exchange-13bb37b6a811451accc14b3501173637f2c28d10.zip
activated tests for conflict wrt denom and age commitment
In src/testing/test_exchange_api_conflicts.c we test the conflicts when two or more coins with the same private key have either different denominations or different age restrictions. Note that the test for different denominations does not fully work for CS: Even with the same master secret, the private keys also differ due to the random choice of the nonce. Fixes #7276
Diffstat (limited to 'src/testing/Makefile.am')
-rw-r--r--src/testing/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/testing/Makefile.am b/src/testing/Makefile.am
index 03118d77a..ae713ab67 100644
--- a/src/testing/Makefile.am
+++ b/src/testing/Makefile.am
@@ -155,6 +155,7 @@ check_PROGRAMS = \
test_exchange_api_rsa \
test_exchange_api_age_restriction_cs \
test_exchange_api_age_restriction_rsa \
+ test_exchange_api_conflicts_cs \
test_exchange_api_conflicts_rsa \
test_exchange_api_keys_cherry_picking_cs \
test_exchange_api_keys_cherry_picking_rsa \