summaryrefslogtreecommitdiff
path: root/src/sq/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-11-12 22:25:59 +0100
committerChristian Grothoff <christian@grothoff.org>2020-11-12 22:25:59 +0100
commit45d621f5ff16c8c6a559f9e865704e8090885799 (patch)
treeda1fa1269f2202b6dbd68865a72b12941f7acbe2 /src/sq/Makefile.am
parent2ad4cee183dde4d40171dc9222fa754bbf341cae (diff)
downloadexchange-45d621f5ff16c8c6a559f9e865704e8090885799.tar.gz
exchange-45d621f5ff16c8c6a559f9e865704e8090885799.tar.bz2
exchange-45d621f5ff16c8c6a559f9e865704e8090885799.zip
add -lgcov flag for coverage analysis
Diffstat (limited to 'src/sq/Makefile.am')
-rw-r--r--src/sq/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/src/sq/Makefile.am b/src/sq/Makefile.am
index ee4c5eba7..93948e773 100644
--- a/src/sq/Makefile.am
+++ b/src/sq/Makefile.am
@@ -12,23 +12,22 @@ lib_LTLIBRARIES = \
libtalersq_la_SOURCES = \
sq_query_helper.c \
sq_result_helper.c
-
libtalersq_la_LIBADD = \
$(top_builddir)/src/util/libtalerutil.la \
-lgnunetutil -ljansson \
- -lsqlite3 $(XLIB)
-
+ -lsqlite3 \
+ $(XLIB)
libtalersq_la_LDFLAGS = \
$(SQLITE_LDFLAGS) \
-version-info 0:0:0 \
-export-dynamic -no-undefined
-TESTS = \
- test_sq
-
check_PROGRAMS= \
test_sq
+TESTS = \
+ $(check_PROGRAMS)
+
test_sq_SOURCES = \
test_sq.c
test_sq_LDADD = \
@@ -37,4 +36,5 @@ test_sq_LDADD = \
-lgnunetsq \
-lgnunetutil \
-ljansson \
- -lsqlite3 $(XLIB)
+ -lsqlite3 \
+ $(XLIB)