summaryrefslogtreecommitdiff
path: root/src/mintdb/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2015-03-28 11:06:00 +0100
committerChristian Grothoff <christian@grothoff.org>2015-03-28 11:06:00 +0100
commitc626ccac51dc968725b2ead1ecb0cebedd9987fc (patch)
tree3acda45b9071865598d2b2670bf6b4bc3f29a57f /src/mintdb/Makefile.am
parenteae1896a4bfc02b5d7586f81bbedfea69b29acc8 (diff)
downloadexchange-c626ccac51dc968725b2ead1ecb0cebedd9987fc.tar.gz
exchange-c626ccac51dc968725b2ead1ecb0cebedd9987fc.tar.bz2
exchange-c626ccac51dc968725b2ead1ecb0cebedd9987fc.zip
second round of renamefest
Diffstat (limited to 'src/mintdb/Makefile.am')
-rw-r--r--src/mintdb/Makefile.am68
1 files changed, 68 insertions, 0 deletions
diff --git a/src/mintdb/Makefile.am b/src/mintdb/Makefile.am
new file mode 100644
index 000000000..ceaa2e210
--- /dev/null
+++ b/src/mintdb/Makefile.am
@@ -0,0 +1,68 @@
+# This Makefile.am is in the public domain
+AM_CPPFLAGS = -I$(top_srcdir)/src/include -I$(top_srcdir)/src/pq/ $(POSTGRESQL_CPPFLAGS)
+
+plugindir = $(libdir)/taler
+
+plugin_LTLIBRARIES = \
+ libtaler_plugin_mintdb_postgres.la
+
+EXTRA_DIST = plugin_mintdb_common.c
+
+libtaler_plugin_mintdb_postgres_la_SOURCES = \
+ plugin_mintdb_postgres.c
+libtaler_plugin_mintdb_postgres_la_LIBADD = \
+ $(LTLIBINTL)
+libtaler_plugin_mintdb_postgres_la_LDFLAGS = \
+ $(TALER_PLUGIN_LDFLAGS) \
+ -lpq \
+ -lgnunetutil
+
+lib_LTLIBRARIES = \
+ libtalermintdb.la
+
+libtalermintdb_la_SOURCES = \
+ mintdb_keyio.c \
+ mintdb_plugin.c
+
+libtalermintdb_la_LIBADD = \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil
+
+libtalermintdb_la_LDFLAGS = \
+ $(POSTGRESQL_LDFLAGS) \
+ -version-info 0:0:0 \
+ -no-undefined
+
+
+check_PROGRAMS = \
+ test-mintdb-deposits \
+ test-mintdb-keyio \
+ test-mintdb-postgres
+
+test_mintdb_deposits_SOURCES = \
+ test_mintdb_deposits.c
+test_mintdb_deposits_LDADD = \
+ libtalermintdb.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ $(top_srcdir)/src/pq/libtalerpq.la \
+ -lgnunetutil \
+ -ljansson \
+ -lpq
+
+test_mintdb_keyio_SOURCES = \
+ test_mintdb_keyio.c
+test_mintdb_keyio_LDADD = \
+ libtalermintdb.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ $(top_srcdir)/src/pq/libtalerpq.la \
+ -lgnunetutil
+
+test_mintdb_postgres_SOURCES = \
+ test_mintdb.c
+test_mintdb_postgres_LDADD = \
+ libtalermintdb.la \
+ $(top_srcdir)/src/util/libtalerutil.la \
+ $(top_srcdir)/src/pq/libtalerpq.la \
+ -lgnunetutil -ljansson
+EXTRA_test_mintdb_postgres_DEPENDENCIES = \
+ libtaler_plugin_mintdb_postgres.la