summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2020-01-12 20:22:18 +0100
committerChristian Grothoff <christian@grothoff.org>2020-01-12 20:22:18 +0100
commit58b78da001e46675205c80818e85d4996f4648f2 (patch)
tree5038e51ec9c333f6a56ba3b0614d4e47ce4a7e45 /src/lib/Makefile.am
parent636c148c0755498738e9e25c943405d55e30c9fc (diff)
downloadexchange-58b78da001e46675205c80818e85d4996f4648f2.tar.gz
exchange-58b78da001e46675205c80818e85d4996f4648f2.tar.bz2
exchange-58b78da001e46675205c80818e85d4996f4648f2.zip
merge revocation tests
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am19
1 files changed, 0 insertions, 19 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index cc7a84771..a06776269 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -161,7 +161,6 @@ check_PROGRAMS = \
test_exchange_api_keys_cherry_picking \
test_exchange_api_overlapping_keys_bug \
test_exchange_api \
- test_exchange_api_revocation \
test_auditor_api_version \
test_auditor_api
@@ -192,10 +191,6 @@ AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=
TESTS = \
$(check_PROGRAMS)
-# expected to fail for now: test incomplete, feature not implemented!
-#XFAIL_TESTS = \
-# test_exchange_api_revocation
-
test_exchange_api_SOURCES = \
test_exchange_api.c
test_exchange_api_LDADD = \
@@ -211,20 +206,6 @@ test_exchange_api_LDADD = \
-lgnunetutil \
-ljansson
-test_exchange_api_revocation_SOURCES = \
- test_exchange_api_revocation.c
-test_exchange_api_revocation_LDADD = \
- libtalertesting.la \
- libtalerexchange.la \
- $(LIBGCRYPT_LIBS) \
- $(top_builddir)/src/bank-lib/libtalerfakebank.la \
- $(top_builddir)/src/bank-lib/libtalerbank.la \
- $(top_builddir)/src/json/libtalerjson.la \
- $(top_builddir)/src/util/libtalerutil.la \
- -lgnunetcurl \
- -lgnunetutil \
- -ljansson
-
test_exchange_api_overlapping_keys_bug_SOURCES = \
test_exchange_api_overlapping_keys_bug.c
test_exchange_api_overlapping_keys_bug_LDADD = \