summaryrefslogtreecommitdiff
path: root/src/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2023-08-24 20:50:47 +0200
committerChristian Grothoff <christian@grothoff.org>2023-08-24 20:50:47 +0200
commit378855142edc575c55b446f34d748ef3c4fe74f7 (patch)
tree7e1771a11a25a5dbd787f34ac0927b7574c6f236 /src/lib/Makefile.am
parent4f2127c69a95aadce96b1cfe441721045c8766c8 (diff)
downloadexchange-378855142edc575c55b446f34d748ef3c4fe74f7.tar.gz
exchange-378855142edc575c55b446f34d748ef3c4fe74f7.tar.bz2
exchange-378855142edc575c55b446f34d748ef3c4fe74f7.zip
implement STEFAN value calculation
Diffstat (limited to 'src/lib/Makefile.am')
-rw-r--r--src/lib/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/lib/Makefile.am b/src/lib/Makefile.am
index f69a4e81a..6ff8e2371 100644
--- a/src/lib/Makefile.am
+++ b/src/lib/Makefile.am
@@ -74,6 +74,7 @@ libtalerexchange_la_SOURCES = \
exchange_api_reserves_history.c \
exchange_api_reserves_open.c \
exchange_api_reserves_status.c \
+ exchange_api_stefan.c \
exchange_api_transfers_get.c \
exchange_api_withdraw.c \
exchange_api_withdraw2.c
@@ -107,5 +108,21 @@ libtalerauditor_la_LIBADD = \
-lgnunetjson \
-lgnunetutil \
-ljansson \
+ -lm \
$(LIBGNURLCURL_LIBS) \
$(XLIB)
+
+
+check_PROGRAMS = \
+ test_stefan
+
+TESTS = \
+ $(check_PROGRAMS)
+
+
+test_stefan_SOURCES = \
+ test_stefan.c
+test_stefan_LDADD = \
+ $(top_builddir)/src/lib/libtalerexchange.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lgnunetutil