summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorJoseph <Joseph.xu@efrei.net>2022-12-29 08:32:52 -0500
committerJoseph <Joseph.xu@efrei.net>2023-01-03 05:28:47 -0500
commit1c104ddf28082a50718cb3d34fdc098a26eb3883 (patch)
tree8d5136ad51f46ece28c0d1d47a92713b7f80f108 /src/exchangedb/Makefile.am
parent2a4aa9ebae19dae95b859cf37c9e317f960ef9ba (diff)
downloadexchange-1c104ddf28082a50718cb3d34fdc098a26eb3883.tar.gz
exchange-1c104ddf28082a50718cb3d34fdc098a26eb3883.tar.bz2
exchange-1c104ddf28082a50718cb3d34fdc098a26eb3883.zip
insert
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 2f6500278..303f04fb8 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -297,6 +297,7 @@ check_PROGRAMS = \
test-exchangedb-by-j-postgres\
test-exchangedb-batch-reserves-in-insert-postgres\
test-exchangedb-populate-table-postgres
+
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
TESTS = \
test-exchangedb-postgres\
@@ -305,7 +306,6 @@ TESTS = \
test-exchangedb-batch-reserves-in-insert-postgres\
test-exchangedb-populate-table-postgres
-
test_exchangedb_postgres_SOURCES = \
test_exchangedb.c
test_exchangedb_postgres_LDADD = \
@@ -399,5 +399,6 @@ bench_db_postgres_LDADD = \
-lgnunetutil \
$(XLIB)
+
EXTRA_test_exchangedb_postgres_DEPENDENCIES = \
libtaler_plugin_exchangedb_postgres.la