summaryrefslogtreecommitdiff
path: root/src/exchangedb/Makefile.am
diff options
context:
space:
mode:
authorMarco Boss <bossm8@bfh.ch>2022-04-02 09:28:25 +0200
committerMarco Boss <bossm8@bfh.ch>2022-04-02 09:28:25 +0200
commit1b76ba5e9a976d431eae4cdc464c698122f5fbf0 (patch)
tree0e58e114a86ab517a659bd42c86ca400acf463c8 /src/exchangedb/Makefile.am
parent6c66f6f5cffa6b33ecd41cfc0ed92ab76185bf06 (diff)
parent0ba219fe5b02d8b22be72e6320c5d7e31c894995 (diff)
downloadexchange-1b76ba5e9a976d431eae4cdc464c698122f5fbf0.tar.gz
exchange-1b76ba5e9a976d431eae4cdc464c698122f5fbf0.tar.bz2
exchange-1b76ba5e9a976d431eae4cdc464c698122f5fbf0.zip
Include sharding sql logic
Diffstat (limited to 'src/exchangedb/Makefile.am')
-rw-r--r--src/exchangedb/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/exchangedb/Makefile.am b/src/exchangedb/Makefile.am
index 2eb1eb0ad..305de431c 100644
--- a/src/exchangedb/Makefile.am
+++ b/src/exchangedb/Makefile.am
@@ -19,9 +19,23 @@ sql_DATA = \
benchmark-0001.sql \
exchange-0000.sql \
exchange-0001.sql \
- partition-0001.sql \
+ shard-0001.sql \
drop0001.sql
+BUILT_SOURCES = \
+ shard-0001.sql \
+ exchange-0001.sql
+
+CLEANFILES = \
+ shard-0001.sql \
+ exchange-0001.sql
+
+exchange-0001.sql: common-0001.sql exchange-0001-part.sql
+ cat common-0001.sql exchange-0001-part.sql >$@
+
+shard-0001.sql: common-0001.sql
+ cp common-0001.sql $@
+
EXTRA_DIST = \
exchangedb.conf \
exchangedb-postgres.conf \