summaryrefslogtreecommitdiff
path: root/src/exchange/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2017-06-11 11:48:06 +0200
committerChristian Grothoff <christian@grothoff.org>2017-06-11 11:48:06 +0200
commit110d0cc71cc4814182bb2d38c3cb304abe5d5407 (patch)
treed6646553acf3f2318b54220b5d8a675b96938033 /src/exchange/Makefile.am
parenta57cf67f31e89aab59a39daf3cca35509c5dc8b8 (diff)
downloadexchange-110d0cc71cc4814182bb2d38c3cb304abe5d5407.tar.gz
exchange-110d0cc71cc4814182bb2d38c3cb304abe5d5407.tar.bz2
exchange-110d0cc71cc4814182bb2d38c3cb304abe5d5407.zip
start test case for #4956
Diffstat (limited to 'src/exchange/Makefile.am')
-rw-r--r--src/exchange/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/exchange/Makefile.am b/src/exchange/Makefile.am
index 899f39684..92a8556a0 100644
--- a/src/exchange/Makefile.am
+++ b/src/exchange/Makefile.am
@@ -97,8 +97,23 @@ test_taler_exchange_aggregator_postgres_LDADD = \
-ljansson \
-lpthread
+test_taler_exchange_wirewatch_postgres_SOURCES = \
+ test_taler_exchange_wirewatch.c
+test_taler_exchange_wirewatch_postgres_LDADD = \
+ $(LIBGCRYPT_LIBS) \
+ $(top_builddir)/src/exchangedb/libtalerexchangedb.la \
+ $(top_builddir)/src/bank-lib/libtalerfakebank.la \
+ $(top_builddir)/src/json/libtalerjson.la \
+ $(top_builddir)/src/util/libtalerutil.la \
+ -lmicrohttpd \
+ -lgnunetutil \
+ -lgnunetjson \
+ -ljansson \
+ -lpthread
+
check_PROGRAMS = \
- test_taler_exchange_aggregator-postgres
+ test_taler_exchange_aggregator-postgres \
+ test_taler_exchange_wirewatch-postgres
AM_TESTS_ENVIRONMENT=export TALER_PREFIX=$${TALER_PREFIX:-@libdir@};export PATH=$${TALER_PREFIX:-@prefix@}/bin:$$PATH;
@@ -109,6 +124,7 @@ TESTS = \
EXTRA_DIST = \
test-taler-exchange-aggregator-postgres.conf \
+ test-taler-exchange-wirewatch-postgres.conf \
test_taler_exchange_httpd_home/.local/share/taler/exchange/offline-keys/master.priv \
test_taler_exchange_httpd.conf \
exchange.conf \